]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: Use python3targetconfig to fix reproducibility issue
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Oct 2021 10:41:41 +0000 (11:41 +0100)
committerAnuj Mittal <anuj.mittal@intel.com>
Wed, 20 Oct 2021 14:54:01 +0000 (22:54 +0800)
We're seeing pthread being linked sometimes and not others leading to
non-reproducible target binaries. The reason is mixing the native python
config with the target one. We should use the target one.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 1bc5378db760963e2ad46542f2907dd6a592eb66)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-core/libxml/libxml2_2.9.10.bb

index ce4f9a334080279995ab730d257b79bf23890f4f..cabf9118169b82f1037bc78fb6e4204846fe7673 100644 (file)
@@ -47,7 +47,7 @@ PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
 
 inherit autotools pkgconfig binconfig-disabled ptest
 
-inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
 
 RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell  python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"