]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils 2.16, 2.17.50.0.5: make them provide 'ar' and 'strings' via update-alternatives
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 27 Apr 2007 14:04:42 +0000 (14:04 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 27 Apr 2007 14:04:42 +0000 (14:04 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1571 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/binutils/binutils.inc
meta/packages/binutils/binutils_2.16.bb
meta/packages/binutils/binutils_2.17.50.0.5.bb

index 680e579a062b0724365c03ab8daffa442109c4fc..e0440b370a29538748cd95f4350417c22fa58f4b 100644 (file)
@@ -1,6 +1,11 @@
+DESCRIPTION = "A GNU collection of binary utilities"
+HOMEPAGE = "http://www.gnu.org/software/binutils/"
+SECTION = "devel"
+LICENSE = "GPL"
+
 inherit autotools gettext
 
-PACKAGES = "${PN} ${PN}-dev ${PN}-doc ${PN}-symlinks"
+PACKAGES += "${PN}-symlinks"
 
 FILES_${PN} = " \
        ${bindir}/${TARGET_PREFIX}* \
@@ -28,6 +33,9 @@ FILES_${PN}-symlinks = " \
        ${bindir}/size \
        ${bindir}/strip"
 
+S = "${WORKDIR}/binutils-${PV}"
+B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
+
 EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} \
                --enable-shared"
 
@@ -60,6 +68,13 @@ export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
 do_configure () {
        (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
        oe_runconf
+#
+# must prime config.cache to ensure the build of libiberty
+#
+       mkdir -p ${B}/build-${BUILD_SYS}
+       for i in ${CONFIG_SITE}; do
+               cat $i >> ${B}/build-${BUILD_SYS}/config.cache
+       done
 }
 
 do_stage () {
index c56f227d58e883c3ae8a0f39e1cd9708d160e4ac..12719800f6d451ee7985754c1c2306aac725c49e 100644 (file)
@@ -1,11 +1,9 @@
-DESCRIPTION = "A GNU collection of binary utilities"
-HOMEPAGE = "http://www.gnu.org/software/binutils/"
-SECTION = "devel"
-LICENSE = "GPL"
-PR = "r7"
+require binutils.inc
+
+PR = "r8"
 
-SRC_URI = \
-    "http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
+SRC_URI = "\
+     http://ftp.gnu.org/gnu/binutils/binutils-${PV}.tar.bz2 \
      file://ld_makefile.patch;patch=1 \
      file://better_file_error.patch;patch=1 \
      file://signed_char_fix.patch;patch=1 \
@@ -18,8 +16,3 @@ SRC_URI += "file://binutils-2.16-linux-uclibc.patch;patch=1"
 # thumb support patches
 SRC_URI += "file://binutils-2.16-thumb-trampoline.patch;patch=1"
 SRC_URI += "file://binutils-2.16-thumb-glue.patch;patch=1"
-
-S = "${WORKDIR}/binutils-${PV}"
-B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
-
-require binutils.inc
index aa3d15bd9f2d09de208198fd22bbd7ccb06a12a7..63147755bc8f6166bae3d7bc6eb6c990a8818ebd 100644 (file)
@@ -1,39 +1,6 @@
-DESCRIPTION = "A GNU collection of binary utilities"
-HOMEPAGE = "http://www.gnu.org/software/binutils/"
-SECTION = "devel"
-LICENSE = "GPL"
+require binutils.inc
 
-inherit autotools gettext
-
-PACKAGES += "${PN}-symlinks"
-
-FILES_${PN} = " \
-       ${bindir}/${TARGET_PREFIX}* \
-       ${libdir}/lib*-*.so \
-       ${prefix}/${TARGET_SYS}/bin/*"
-
-FILES_${PN}-dev = " \
-       ${includedir} \
-       ${libdir}/*.a \
-       ${libdir}/*.la \
-       ${libdir}/libbfd.so \
-       ${libdir}/libopcodes.so"
-
-FILES_${PN}-symlinks = " \
-       ${bindir}/addr2line \
-       ${bindir}/ar \
-       ${bindir}/as \
-       ${bindir}/c++filt \
-       ${bindir}/gprof \
-       ${bindir}/ld \
-       ${bindir}/nm \
-       ${bindir}/objcopy \
-       ${bindir}/objdump \
-       ${bindir}/ranlib \
-       ${bindir}/readelf \
-       ${bindir}/size \
-       ${bindir}/strings \
-       ${bindir}/strip"
+PR = "r1"
 
 SRC_URI = "\
      http://www.kernel.org/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
@@ -44,87 +11,3 @@ SRC_URI = "\
      file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
      file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
      "
-
-S = "${WORKDIR}/binutils-${PV}"
-B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
-
-EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} \
-               --enable-shared"
-
-# This is necessary due to a bug in the binutils Makefiles
-EXTRA_OEMAKE = "configure-build-libiberty all"
-
-export AR = "${HOST_PREFIX}ar"
-export AS = "${HOST_PREFIX}as"
-export LD = "${HOST_PREFIX}ld"
-export NM = "${HOST_PREFIX}nm"
-export RANLIB = "${HOST_PREFIX}ranlib"
-export OBJCOPY = "${HOST_PREFIX}objcopy"
-export OBJDUMP = "${HOST_PREFIX}objdump"
-
-export AR_FOR_TARGET = "${TARGET_PREFIX}ar"
-export AS_FOR_TARGET = "${TARGET_PREFIX}as"
-export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
-export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
-export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
-
-export CC_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-export CXX_FOR_HOST = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-
-export CC = "${CCACHE} ${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-
-do_configure () {
-       (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
-       oe_runconf
-#
-# must prime config.cache to ensure the build of libiberty
-#
-       mkdir -p ${B}/build-${BUILD_SYS}
-       for i in ${CONFIG_SITE}; do
-               cat $i >> ${B}/build-${BUILD_SYS}/config.cache
-       done
-
-}
-
-do_stage () {
-       oe_libinstall -so -a -C opcodes libopcodes ${STAGING_LIBDIR}/
-       oe_libinstall -a -C libiberty libiberty ${STAGING_LIBDIR}/
-       oe_libinstall -so -a -C bfd libbfd ${STAGING_LIBDIR}/
-       install -m 0644 ${S}/include/dis-asm.h ${STAGING_INCDIR}/
-       install -m 0644 ${S}/include/symcat.h ${STAGING_INCDIR}/
-       install -m 0644 ${S}/include/libiberty.h ${STAGING_INCDIR}/
-       install -m 0644 ${S}/include/ansidecl.h ${STAGING_INCDIR}/
-       install -m 0644 ${S}/include/bfdlink.h ${STAGING_INCDIR}/
-       install -m 0644 bfd/bfd.h ${STAGING_INCDIR}/
-}
-
-do_install () {
-       autotools_do_install
-
-       # We don't really need these, so we'll remove them...
-       rm -rf ${D}${libdir}/ldscripts
-
-       # Fix the /usr/${TARGET_SYS}/bin/* links
-       for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
-               rm -f $l
-               ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
-                       | tr -s / \
-                       | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
-       done
-
-       # Install the libiberty header
-       install -d ${D}${includedir}
-       install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
-       install -m 644 ${S}/include/libiberty.h ${D}${includedir}
-
-       cd ${D}${bindir}
-
-       # Symlinks for ease of running these on the native target
-       for p in ${TARGET_SYS}-* ; do
-               ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
-       done
-}