]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-smartpm: Have native smart use nativepython
authorRandy Witt <randy.e.witt@linux.intel.com>
Fri, 10 Jul 2015 21:03:21 +0000 (14:03 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jul 2015 21:53:22 +0000 (22:53 +0100)
Currently when trying to use smart via devshell or in the bitbake
environment, it will fail without inheriting pythonnative. Since the
native tools should "just work" use nativepython in the shebang line for
smart.

Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-smartpm_git.bb

index ed786e458e48c988bbf64caab193521540454582..18df892b9b4c14e6a3012e97f4e23c8f31e88f64 100644 (file)
@@ -97,6 +97,7 @@ add_native_wrapper() {
 }
 
 do_install_append_class-native() {
+        sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' ${D}${bindir}/smart
         add_native_wrapper
 }