]> code.ossystems Code Review - openembedded-core.git/commitdiff
flumotion: merged OE improvements (fixed packaging, more revdeps)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Apr 2008 05:17:46 +0000 (05:17 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 3 Apr 2008 05:17:46 +0000 (05:17 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4160 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta-extras/packages/flumotion/flumotion_0.4.1.bb

index 31f40528455296c993634707d82262a233049841..cb7ab10a81a1c4d123203cba7afe11fcfdcecf43 100644 (file)
@@ -1,13 +1,19 @@
 DESCRIPTION = "Fluendo Streaming Server"
 LICENSE = "GPL"
-DEPENDS = "gstreamer python-gst twisted python-pygtk2"
-RDEPENDS = "python-twisted-core python-twisted-web python-core python-gst"
-RDEPENDS_${PN}-gui = "${PN} python-pygtk"
-PR = "r4"
+DEPENDS = "gstreamer python-imaging python-gst twisted python-pygtk"
+RDEPENDS = "python-resource python-pprint python-threading \
+            python-imaging python-xml python-curses \
+            python-compression python-fcntl python-pygobject \
+            python-pickle python-netclient python-datetime \
+            python-crypt python-twisted-core python-twisted-web \
+            python-lang python-zopeinterface  python-textutils \
+            python-gst python-misc"
+RDEPENDS_${PN}-gui = "${PN} python-pygtk python-pycairo"
+PR = "r9"
 
 SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
            file://python-path.patch;patch=1 \
-          file://no-check-for-python-stuff.patch;patch=1"
+           file://no-check-for-python-stuff.patch;patch=1"
 
 inherit autotools distutils-base pkgconfig
 
@@ -17,6 +23,7 @@ EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
 
 PACKAGES =+ "flumotion-gui"
 
+FILES_${PN}-dbg += "${libdir}/flumotion/python/flumotion/extern/*/.debug/*"
 FILES_${PN} = "${bindir} ${sbindir} ${libdir}/flumotion"
 FILES_${PN}-dev += "${libdir}/pkgconfig"
 FILES_${PN}-gui = "${bindir}/flumotion-admin ${bindir}/flumotion-tester \