]> code.ossystems Code Review - openembedded-core.git/commitdiff
libacpi: Use the cross strip instead of host strip
authorNitin A Kamble <nitin.a.kamble@intel.com>
Wed, 7 Dec 2011 19:32:36 +0000 (11:32 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Dec 2011 21:50:09 +0000 (21:50 +0000)
to avoid this build error on x32:

| strip: Unable to recognise the format of the input file `test-libacpi'
| make: *** [test-libacpi] Error 1
| ERROR: oe_runmake failed

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch [new file with mode: 0644]
meta/recipes-bsp/libacpi/libacpi_0.2.bb

diff --git a/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch b/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch
new file mode 100644 (file)
index 0000000..c9ad668
--- /dev/null
@@ -0,0 +1,23 @@
+UpstreamStatus: Pending
+
+Used the cross strip instead of host strip to avoid this build error:
+
+| strip: Unable to recognise the format of the input file `test-libacpi'
+| make: *** [test-libacpi] Error 1
+| ERROR: oe_runmake failed
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/07
+
+Index: libacpi-0.2/Makefile
+===================================================================
+--- libacpi-0.2.orig/Makefile
++++ libacpi-0.2/Makefile
+@@ -39,7 +39,7 @@ libacpi.so: ${OBJ}
+ test-libacpi: ${OBJ_test}
+       @echo LD $@
+       @${CC} -o $@ ${OBJ_test} ${LDFLAGS}
+-      @strip $@
++      @${STRIP} $@
+ install: all
+       @echo installing header to ${DESTDIR}${PREFIX}/include
index 82fe8f8e2cad7294ea900333fad06a1cd65e7aa5..2d98fae1af1d1d9849617ee0a5f16fbc5c48282c 100644 (file)
@@ -5,11 +5,12 @@ SECTION = "base"
 HOMEPAGE = "http://www.ngolde.de/libacpi.html"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fec17f82f16630adf2dfb7d2a46f21c5"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "http://www.ngolde.de/download/libacpi-${PV}.tar.gz \
           file://makefile-fix.patch \
-          file://libacpi_fix_for_x32.patch "
+          file://libacpi_fix_for_x32.patch \
+          file://use_correct_strip_in_cross_environment.patch"
 
 SRC_URI[md5sum] = "05b53dd7bead66dda35fec502b91066c"
 SRC_URI[sha256sum] = "13086e31d428b9c125954d48ac497b754bbbce2ef34ea29ecd903e82e25bad29"