]> code.ossystems Code Review - openembedded-core.git/commitdiff
psplash: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 01:32:16 +0000 (01:32 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:17:39 +0000 (13:17 +0000)
Allow out of tree builds to work by using the full path to the
source file.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/psplash/psplash_git.bb

index 482670d0b4143499c0a7303dd570a36696f1a54b..5413b240575b1b9f01c0f8e0d48f5be791a588e8 100644 (file)
@@ -87,7 +87,7 @@ python do_compile () {
             shutil.copyfile(localfile, destfile)
         # For some reason just updating the header is not enough, we have to touch the .c
         # file in order to get it to rebuild
-        os.utime("psplash.c", None)
+        os.utime("%s/psplash.c" % d.getVar('S', True), None)
         bb.build.exec_func("oe_runmake", d)
         shutil.copyfile("psplash", outputfile)
 }