]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm-init: add xuser to group audio
authorDongxiao Xu <dongxiao.xu@intel.com>
Tue, 15 Mar 2011 07:16:34 +0000 (15:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Mar 2011 17:48:27 +0000 (17:48 +0000)
add rootless X user to group audio to access /dev/snd/*

Fixes [YOCTO #799]

CC: Ke Yu <ke.yu@intel.com>
Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-graphics/x11-common/xserver-nodm-init.bb

index a93acc9ee34d2bf772cf930b744ff25a3f8fcf03..abc25db9cc2d8109c2faea229e4fde68d349d9ca 100644 (file)
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
 PRIORITY = "optional"
-PR = "r24"
+PR = "r25"
 RDEPENDS_${PN} = "dbus-wait sudo"
 
 SRC_URI = "file://xserver-nodm \
@@ -30,12 +30,13 @@ pkg_postinst_${PN} () {
     fi
 
     if [ -f /etc/X11/Xusername ]; then
-        # create the rootless X user, and add user to group tty, video
+        # create the rootless X user, and add user to group tty, video, audio
         username=`cat /etc/X11/Xusername`
         adduser --disabled-password $username
         # FIXME: use addgroup if busybox addgroup is ready
         sed -i -e "s/^video:.*/&${username}/g" /etc/group
         sed -i -e "s/^tty:.*/&${username}/g" /etc/group
+        sed -i -e "s/^audio:.*/&${username}/g" /etc/group
     fi
 }