]> code.ossystems Code Review - openembedded-core.git/commitdiff
python[3]-setuptools: inherit setuptools
authorTim Orling <timothy.t.orling@linux.intel.com>
Thu, 4 Jan 2018 22:56:44 +0000 (14:56 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 6 Jan 2018 10:11:42 +0000 (10:11 +0000)
* distutils[3].bbclass was not including pkg_resources module
* Drop uneeded DISTUTILS_INSTALL_ARGS as setuptools[3].bbclass provides it

Fixes [YOCTO #12148]

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-setuptools_36.2.7.bb
meta/recipes-devtools/python/python3-setuptools_36.2.7.bb

index 526474c7ea5d555be94247ffdb3a993213c72b91..0efacc137af26d5318e1ac198582497c35f615c2 100644 (file)
@@ -5,9 +5,7 @@ PROVIDES = "python-distribute"
 DEPENDS += "python"
 DEPENDS_class-native += "python-native"
 
-inherit distutils
-
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
+inherit setuptools
 
 RDEPENDS_${PN} = "\
   python-stringold \
index 63f241809e00e5184197fa42df019bb29009f0db..a7bca9740269de514f3e0826521fb344d6965abb 100644 (file)
@@ -4,15 +4,10 @@ DEPENDS += "python3"
 DEPENDS_class-native += "python3-native"
 DEPENDS_class-nativesdk += "nativesdk-python3"
 
-inherit distutils3
+inherit setuptools3
 
-DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
-
-# The installer puts the wrong path in the setuptools.pth file.  Correct it.
 do_install_append() {
-    rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
     mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
-    echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
 }
 
 RDEPENDS_${PN}_class-native = "\