]> code.ossystems Code Review - openembedded-core.git/commitdiff
gstreamer: use autotools_stage_all so libtool files will be mangled properly
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 14 Nov 2007 11:11:33 +0000 (11:11 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 14 Nov 2007 11:11:33 +0000 (11:11 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3159 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gstreamer/gstreamer_0.10.14.bb

index c6134d7fa7fdea78e8c2a37e7b8effafdccee359..7a37770f7f3dfd87ab1ec9342baa0ad800d4443d 100644 (file)
@@ -5,6 +5,7 @@ PRIORITY = "optional"
 LICENSE = "LGPL"
 HOMEPAGE = "http://www.gstreamer.net/"
 DEPENDS = "glib-2.0 gettext-native libxml2 bison-native flex-native"
+PR = "r1"
 
 inherit autotools pkgconfig
 
@@ -20,14 +21,8 @@ EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=
 #}
 
 do_stage() {
-       oe_runmake install prefix=${STAGING_DIR_HOST}${layout_prefix} \
-              bindir=${STAGING_BINDIR} \
-              includedir=${STAGING_INCDIR} \
-              libdir=${STAGING_LIBDIR} \
-              datadir=${STAGING_DATADIR} \
-              mandir=${STAGING_DIR_HOST}${layout_mandir}
+       autotools_stage_all
 }
 
 FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
 FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
-