]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-panel: silence some pointless warnings
authorRoss Burton <ross.burton@intel.com>
Thu, 26 Sep 2013 16:06:36 +0000 (17:06 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Sep 2013 16:48:30 +0000 (17:48 +0100)
The battery applet emits a warning if the hardware doesn't have a battery (it
shouldn't) and the parser emits a warning if two separators are used in a row
(which happens if the hardware has a keyboard).  Silence these with a patch from
upstream.

[ YOCTO #4061 ]

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/matchbox-panel-2/files/silence-warnings.patch [new file with mode: 0644]
meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb

diff --git a/meta/recipes-sato/matchbox-panel-2/files/silence-warnings.patch b/meta/recipes-sato/matchbox-panel-2/files/silence-warnings.patch
new file mode 100644 (file)
index 0000000..45ba9a0
--- /dev/null
@@ -0,0 +1,64 @@
+Don't warn if the machine doesn't actually have a battery, or if the applets
+string contains consecutive separators.
+
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/applets/battery/battery-acpi.c b/applets/battery/battery-acpi.c
+index 6515cb0..c44dd12 100644
+--- a/applets/battery/battery-acpi.c
++++ b/applets/battery/battery-acpi.c
+@@ -14,8 +14,6 @@ int batt_state, ac_state;
+ int pm_support(void)
+ {
+       if(check_acpi_support() == NOT_SUPPORTED){
+-              g_warning("No ACPI support\n");
+-
+               return 0;
+       }
+@@ -32,8 +30,9 @@ const char* pm_battery_icon(void)
+       const char *icon;
+       battery_t *binfo;
++        /* No battery available (not present, disabled, or something
++           else. Silently do nothing. */
+       if (batt_state != SUCCESS) {
+-              g_warning("Couldnt initialize ACPI battery\n");
+               return NULL;
+       }
+diff --git a/applets/battery/battery-apm.c b/applets/battery/battery-apm.c
+index 5467438..2f39cb6 100644
+--- a/applets/battery/battery-apm.c
++++ b/applets/battery/battery-apm.c
+@@ -10,8 +10,6 @@
+ int pm_support(void)
+ {
+       if (1 == apm_exists ()) {
+-                g_warning ("No APM support");
+-
+                 return 0;
+         }
+diff --git a/matchbox-panel/mb-panel.c b/matchbox-panel/mb-panel.c
+index 2d8cafd..828a36d 100644
+--- a/matchbox-panel/mb-panel.c
++++ b/matchbox-panel/mb-panel.c
+@@ -110,10 +110,15 @@ load_applets (const char    *applets_desc,
+         applets = g_strsplit (applets_desc, ",", -1);
+         for (i = 0; applets[i]; i++) {
++                char *s;
+                 char **bits;
+                 GtkWidget *applet;
+-                bits = g_strsplit (applets[i], ":", 2);
++                s = applets[i];
++                if (s == NULL || s[0] == '\0')
++                        continue;
++
++                bits = g_strsplit (s, ":", 2);
+                 applet = load_applet (bits[0],
+                                       bits[1],
index 1e2a7ae2ad1d6e16fe7d95392ecabadc20aeaffe..eff20f0493fb690a2dd35bf52f44e41b0c589d30 100644 (file)
@@ -19,7 +19,8 @@ RPROVIDES_${PN} = "matchbox-panel"
 RREPLACES_${PN} = "matchbox-panel"
 RCONFLICTS_${PN} = "matchbox-panel"
 
-SRC_URI = "git://git.yoctoproject.org/${BPN}"
+SRC_URI = "git://git.yoctoproject.org/${BPN} \
+           file://silence-warnings.patch"
 
 EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
 EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"