]> code.ossystems Code Review - openembedded-core.git/commitdiff
db: Fix path of arm-thumb patch
authorMark Hatle <mark.hatle@windriver.com>
Fri, 18 Mar 2011 16:33:10 +0000 (11:33 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Mar 2011 23:18:03 +0000 (23:18 +0000)
Newer versions of patch, such as in Fedora 14, don't like ".." within
the middle of the file to be patched path.

In order to fix the issue we have to hand apply the patch instead of using
the normal mechanisms.  Only flaw with the os.system(...) approach is if it
fails we don't get any notification or a resolver failure.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-support/db/db/arm-thumb-mutex_db5.patch
meta/recipes-support/db/db_5.1.19.bb

index 37d0d93abde2846fab0d6c152cce8aa0af358493..51d485499e6bbca9ab9f09964294c01e382b6c03 100644 (file)
@@ -1,5 +1,5 @@
---- db-5.1.19/../src/dbinc/mutex_int.h.orig    2011-01-05 19:21:42.181805366 -0600
-+++ db-5.1.19/../src/dbinc/mutex_int.h 2011-01-05 19:24:53.141853117 -0600
+--- db-5.1.19/src/dbinc/mutex_int.h.orig       2011-01-05 19:21:42.181805366 -0600
++++ db-5.1.19/src/dbinc/mutex_int.h    2011-01-05 19:24:53.141853117 -0600
 @@ -474,6 +474,25 @@
  
  #ifdef LOAD_ACTUAL_MUTEX_CODE
index 919e532be11182851b826ea4380639ba31881c42..94ce180cf9695fdc792137a955a80e1cda5f3784 100644 (file)
@@ -14,11 +14,10 @@ HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
 LICENSE = "BSD Sleepycat"
 VIRTUAL_NAME ?= "virtual/db"
 CONFLICTS = "db3"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-SRC_URI += "file://arm-thumb-mutex_db5.patch;patch=1"
+SRC_URI += "file://arm-thumb-mutex_db5.patch;apply=no"
 
 SRC_URI[md5sum] = "76fcbfeebfcd09ba0b4d96bfdf8d884d"
 SRC_URI[sha256sum] = "0194d4ca9266ba1a1c0bfbc233b18bfd05f63163453c81ebcdfdc7112d5ac850"
@@ -80,6 +79,10 @@ do_configure() {
        oe_runconf
 }
 
+do_patch_append() {
+       os.system("cd ${S}/.. ; patch -p1 -i ${WORKDIR}/arm-thumb-mutex_db5.patch")
+}
+
 do_install_append() {
        mkdir -p ${D}/${includedir}/db51
        #mv ${D}/${includedir}/db_185.h ${D}/${includedir}/db51/.