]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdk-pixbuf: Only apply native cleaning in normal task, not setscene
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 26 Sep 2015 17:12:17 +0000 (18:12 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 28 Sep 2015 10:58:33 +0000 (11:58 +0100)
The previous fix works well for normal tasks since the ordering is always
correct and gdk-pixbuf-native comes first. Setscene ordering is reversed
so we can't rely on this there. Remove the fix in that case since
it breaks more than it solves.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.8.bb

index 2f0ca49b353fcc89fbd1fa21276bef4a3da21f26..68f3850fb7b63cecdccadabb69acde4abb06fbe8 100644 (file)
@@ -106,7 +106,7 @@ SSTATEPREINSTFUNCS_append_class-native = " gdkpixbuf_sstate_preinst"
 SYSROOT_PREPROCESS_FUNCS_append_class-native = " gdkpixbuf_sstate_preinst"
 
 gdkpixbuf_sstate_preinst() {
-       if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]; then
+       if [ "${BB_CURRENTTASK}" = "populate_sysroot" ]; then
                rm -rf ${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/*
        fi
 }