]> code.ossystems Code Review - openembedded-core.git/commitdiff
bison: Use PATH to locate m4
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 00:03:03 +0000 (00:03 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 18 Mar 2013 13:10:06 +0000 (13:10 +0000)
We can specify no path to m4 at configure time and thus avoiding
having a wrapper for that particular problem.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/bison/bison_2.7.bb

index ee2effb1587f3b3e69ae75841922b438065fc255..373651e4de2b48551fc844fcfdbe9015043bfb5b 100644 (file)
@@ -16,6 +16,9 @@ BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.gz \
                 file://dont-depend-on-help2man.patch \
               "
 
+# No point in hardcoding path to m4, just use PATH
+EXTRA_OECONF += "M4=m4"
+
 SRC_URI = "${BASE_SRC_URI} \
            file://fix_cross_manpage_building.patch \
           "
@@ -32,8 +35,6 @@ acpaths = "-I ${S}/m4"
 
 do_install_append_class-native() {
        create_wrapper ${D}/${bindir}/bison \
-               M4=${STAGING_BINDIR_NATIVE}/m4 \
                BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
 }
-#bison-native encodes the staging M4 path
 BBCLASSEXTEND = "native nativesdk"