]> code.ossystems Code Review - openembedded-core.git/commitdiff
rsync: added 2.6.9 from OE
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 11 Dec 2007 13:43:19 +0000 (13:43 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 11 Dec 2007 13:43:19 +0000 (13:43 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3328 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/rsync/files/rsyncd.conf [new file with mode: 0644]
meta/packages/rsync/rsync_2.6.9.bb [new file with mode: 0644]

diff --git a/meta/packages/rsync/files/rsyncd.conf b/meta/packages/rsync/files/rsyncd.conf
new file mode 100644 (file)
index 0000000..845f5b3
--- /dev/null
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+#      path = /
+#      comment = Everything except /etc exposed
+#      exclude = /etc
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb
new file mode 100644 (file)
index 0000000..ab7ae43
--- /dev/null
@@ -0,0 +1,17 @@
+LICENSE = "GPL"
+DESCRIPTION = "A file-synchronization tool"
+SECTION = "console/network"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/rsync-${PV}.tar.gz \
+           file://rsyncd.conf"
+
+inherit autotools
+
+do_install_append() {
+       install -d ${D}/etc
+       install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
+EXTRA_OEMAKE='STRIP=""'