]> code.ossystems Code Review - openembedded-core.git/commitdiff
v86d: Add initscript to activate the framebuffer early in the boot process
authorRichard Purdie <richard@openedhand.com>
Fri, 11 Jan 2008 09:10:16 +0000 (09:10 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 11 Jan 2008 09:10:16 +0000 (09:10 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3463 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/v86d/v86d/fbsetup [new file with mode: 0755]
meta/packages/v86d/v86d_0.1.3.bb

diff --git a/meta/packages/v86d/v86d/fbsetup b/meta/packages/v86d/v86d/fbsetup
new file mode 100755 (executable)
index 0000000..2a409cc
--- /dev/null
@@ -0,0 +1,3 @@
+#!/bin/sh 
+
+/sbin/modprobe uvesafb
index 0a168eef9517956a255b1311f24a2434f2348beb..4cec2542efccc50d2b175dca28714ec2819211d6 100644 (file)
@@ -1,13 +1,18 @@
 DESCRIPTION = "User support binary for the uvesafb kernel module"
-SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-0.1.3.tar.bz2"
+SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-0.1.3.tar.bz2 \
+           file://fbsetup"
 DEPENDS = "virtual/kernel"
 LICENSE = "GPLv2"
+PR = "r3"
 
 RRECOMMENDS_${PN} = "kernel-module-uvesafb"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 COMPATIBLE_MACHINE = "qemux86"
 
+INITSCRIPT_NAME = "fbsetup"
+INITSCRIPT_PARAMS = "start 0 S ."
+
 do_configure () {
        ./configure --default
 }
@@ -19,4 +24,9 @@ do_compile () {
 do_install () {
        install -d ${D}${base_sbindir}
        install v86d ${D}${base_sbindir}/
-}
\ No newline at end of file
+
+        install -d ${D}${sysconfdir}/init.d/
+        install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
+}
+
+inherit update-rc.d