]> code.ossystems Code Review - openembedded-core.git/commitdiff
time: use u-a for time, conflicts with busybox
authorMartin Jansa <Martin.Jansa@gmail.com>
Fri, 11 Nov 2011 12:23:05 +0000 (13:23 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 Nov 2011 11:54:44 +0000 (11:54 +0000)
* it was reported here:
  http://lists.linuxtogo.org/pipermail/openembedded-core/2011-September/009409.html

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
meta/recipes-extended/time/time.inc
meta/recipes-extended/time/time_1.7.bb

index 2d9dab8e8593e2163f68f7109459105f1583a35e..401288b0ceb77b146679a248b23dfeb4c161e9b1 100644 (file)
@@ -6,3 +6,13 @@ SECTION = "utils"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
 
+inherit update-alternatives
+
+do_install_append () {
+        mv ${D}${bindir}/time ${D}${bindir}/time.${PN}
+}
+
+ALTERNATIVE_NAME = "time"
+ALTERNATIVE_LINK = "${bindir}/time"
+ALTERNATIVE_PATH = "${bindir}/time.${PN}"
+ALTERNATIVE_PRIORITY = "100"
index 35afb1ea5a344701598bd4ad8bf4609c87436353..c38608fd9eb3d051026087ef30693a70ec3b489d 100644 (file)
@@ -1,5 +1,7 @@
 require time.inc
 
+PR = "r1"
+
 SRC_URI = "${GNU_MIRROR}/time/time-${PV}.tar.gz \
           file://debian.patch"