]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-keyboard: Make as singleton
authorZhai Edwin <edwin.zhai@intel.com>
Wed, 22 Dec 2010 12:53:50 +0000 (20:53 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 23 Dec 2010 14:28:21 +0000 (14:28 +0000)
Multiple matchbox-keyboard instances would occupy whole screen and cause X
window segfault. Making matchbox-keyboard singleton is one work around.

This patch allow only one instance of matchbox-keyboard based on some mechanism
in matchbox-desktop. In future, an applet and GTK-IM modules in
matchbox-keyboard can be used to automatically map/unmap the virtual keyboard
on demand.

[BUGID #509] got fixed.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/recipes-sato/matchbox-keyboard/files/single-instance.patch [new file with mode: 0644]
meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_svn.bb

diff --git a/meta/recipes-sato/matchbox-keyboard/files/single-instance.patch b/meta/recipes-sato/matchbox-keyboard/files/single-instance.patch
new file mode 100644 (file)
index 0000000..d0adc47
--- /dev/null
@@ -0,0 +1,22 @@
+Multiple matchbox-keyboard instances would occupy whole screen and cause X
+window segfault(Bug 509). Making matchbox-keyboard singleton is one work
+around.
+
+This patch allow only one instance of matchbox-keyboard based on some mechanism
+in matchbox-desktop. In future, an applet and GTK-IM modules in
+matchbox-keyboard can be used to automatically map/unmap the virtual keyboard
+on demand.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+
+Index: matchbox-keyboard/matchbox-keyboard.desktop
+===================================================================
+--- matchbox-keyboard.orig/matchbox-keyboard.desktop   2010-12-22 20:41:40.000000000 +0800
++++ matchbox-keyboard/matchbox-keyboard.desktop        2010-12-22 20:42:12.000000000 +0800
+@@ -6,3 +6,5 @@
+ Icon=matchbox-keyboard.png
+ Categories=Panel;Utility;MB
+ X-MB-INPUT-MECHANSIM=True
++X-MB-SingleInstance=true
++StartupNotify=true
index 0425fec78adb19d947d9f24e854ae2d1cc264862..337738edf8ebf8989e64ceaa738866de526400a2 100644 (file)
@@ -15,6 +15,7 @@ PR = "r4"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
            file://configure_fix.patch;patch=1;maxrev=1819 \
+           file://single-instance.patch;patch=1 \
           file://80matchboxkeyboard.shbg"
 
 S = "${WORKDIR}/${PN}"