]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: Fix PGEN linking errors
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Mon, 23 Mar 2015 21:33:21 +0000 (15:33 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Mar 2015 10:08:00 +0000 (10:08 +0000)
Parallel make races when linking PGEN affects target's python
compilation as well, adds patch from python-native to modify the
Makefile and avoid parallel make races, also updates upstream status

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-native/avoid_parallel_make_races_on_pgen.patch
meta/recipes-devtools/python/python/avoid_parallel_make_races_on_pgen.patch [new file with mode: 0644]
meta/recipes-devtools/python/python_2.7.9.bb

index 1a8f68ebf3ec0f1b05501c87b0eb181815da1fa8..5279e7c3b484c0b81f4e3dc3a8663103df00f60b 100644 (file)
@@ -1,4 +1,4 @@
-Upstream-Status: Inappropriate [embedded specific]
+Upstream-Status: Pending
 
 Avoids parallel make races linking errors when making Parser/PGEN
 
diff --git a/meta/recipes-devtools/python/python/avoid_parallel_make_races_on_pgen.patch b/meta/recipes-devtools/python/python/avoid_parallel_make_races_on_pgen.patch
new file mode 100644 (file)
index 0000000..e9bae32
--- /dev/null
@@ -0,0 +1,27 @@
+Upstream-Status: Pending
+
+Avoids parallel make races linking errors when making Parser/PGEN
+
+- Implements Richard Purdie's idea
+
+Signed-Off-By: Richard Purdie <richard.purdie@linuxfoundation.org>
+Signed-Off-By: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: Python-2.7.9/Makefile.pre.in
+===================================================================
+--- Python-2.7.9.orig/Makefile.pre.in
++++ Python-2.7.9/Makefile.pre.in
+@@ -611,12 +611,10 @@ Modules/grpmodule.o: $(srcdir)/Modules/g
+ Modules/pwdmodule.o: $(srcdir)/Modules/pwdmodule.c $(srcdir)/Modules/posixmodule.h
+-$(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGENSRCS)
++$(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGENSRCS) $(PGEN)
+               @$(MKDIR_P) Include
+-              $(MAKE) $(PGEN)
+               $(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
+ $(GRAMMAR_C): $(GRAMMAR_H) $(GRAMMAR_INPUT) $(PGENSRCS)
+-              $(MAKE) $(GRAMMAR_H)
+               touch $(GRAMMAR_C)
+ $(PGEN):      $(PGENOBJS)
index 4087c2cb13d748f82219f545a1e8090a00413028..6d5b42a42f82d9cc3611737fada4d3a7afede4a7 100644 (file)
@@ -25,6 +25,7 @@ SRC_URI += "\
   file://run-ptest \
   file://parallel-makeinst-create-bindir.patch \
   file://use_sysroot_ncurses_instead_of_host.patch \
+  file://avoid_parallel_make_races_on_pgen.patch \
 "
 
 S = "${WORKDIR}/Python-${PV}"