]> code.ossystems Code Review - openembedded-core.git/commitdiff
prelink: Add prelink-native
authorMark Hatle <mhatle@windriver.com>
Fri, 23 Jul 2010 15:18:07 +0000 (08:18 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Sat, 24 Jul 2010 00:23:53 +0000 (01:23 +0100)
Add the new cross prelink support as the prelink-native integration.

Set the prelinker to use the prelink-cross.git repository as the upstream.

Note: libiberty.a is required on the host at this time

Signed-off-by: Mark Hatle <mhatle@windriver.com>
meta/conf/distro/include/poky-default-revisions.inc
meta/packages/prelink/prelink_git.bb [moved from meta/packages/prelink/prelink_20100106.bb with 72% similarity]

index d3d59274aab5a87d2348c801807247621160769c..44723a0a6d7435559e5e28c4d5cf4e574a9cb5cf 100644 (file)
@@ -104,6 +104,8 @@ SRCREV_pn-oprofileui ??= "197"
 SRCREV_pn-osc-native ??= "9096"
 SRCREV_pn-owl-video ??= "394"
 SRCREV_pn-pkgconfig ??= "66d49f1375fec838bcd301bb4ca2ef76cee0e47c"
+SRCREV_pn-prelink ??= "909470ee441237563d6236c505cb2d02ddc48704"
+SRCREV_pn-prelink-native ??= "909470ee441237563d6236c505cb2d02ddc48704"
 SRCREV_pn-psplash ??= "424"
 SRCREV_pn-pseudo ??= "973e40da8e5abb080cc0b9c9eaff4d84dea5b42c"
 SRCREV_pn-pseudo-native ??= "973e40da8e5abb080cc0b9c9eaff4d84dea5b42c"
similarity index 72%
rename from meta/packages/prelink/prelink_20100106.bb
rename to meta/packages/prelink/prelink_git.bb
index a84aaa267a4b2aeca52463da6c209e9f8da8d046..06078ed68b6fc417aac57db4f2c15190cf66abbf 100644 (file)
@@ -1,12 +1,14 @@
 SECTION = "devel"
-DEPENDS = "elfutils"
+# Need binutils for libiberty.a
+DEPENDS = "elfutils binutils"
 DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
 and executables, so that far fewer relocations need to be resolved at \
 runtime and thus programs come up faster."
-LICENSE = "GPL"
+LICENSE = "GPLv2"
+PV = "1.0+git${SRCPV}"
 PR = "r0"
 
-SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
+SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
            file://prelink.conf \
            file://prelink.cron.daily \
            file://prelink.default"
@@ -14,12 +16,15 @@ SRC_URI = "http://people.redhat.com/jakub/prelink/prelink-${PV}.tar.bz2 \
 TARGET_OS_ORIG := "${TARGET_OS}"
 OVERRIDES_append = ":${TARGET_OS_ORIG}"
 
-S = "${WORKDIR}/prelink"
-
-EXTRA_OECONF = "--disable-64bit"
+S = "${WORKDIR}/git/trunk"
 
 inherit autotools 
 
+BBCLASSEXTEND = "native"
+
+EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
+       --with-bugurl=http://bugzilla.pokylinux.org/"
+
 do_install_append () {
        install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
        install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf