]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: merge OE change of cpuinfo_id to machine_id, fixing gsmd's startup
authorRoss Burton <ross@openedhand.com>
Mon, 4 Aug 2008 13:45:06 +0000 (13:45 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 4 Aug 2008 13:45:06 +0000 (13:45 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5016 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/initscripts/initscripts-1.0/functions
meta/packages/initscripts/initscripts_1.0.bb

index 514618770a7895f7d4e6213eca440b160d561612..689fd32b3947d6f8b10a49cd605e6a7c6f9746aa 100644 (file)
@@ -4,8 +4,8 @@
 #               shell scripts in the /etc/init.d directory.
 #
 
-cpuinfo_id() {         # return the Hardware module ID
-    awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+machine_id() {         # return the machine ID
+    awk 'BEGIN { FS=": " } /Hardware/ { gsub(" ", "_", $2); print tolower($2) } ' </proc/cpuinfo
 }
 
 killproc() {           # kill the named process(es)
index d2fc3d5e52554e0e814c089567a1f8892f839385..377cc14102e7080a460e15dcfdbef54c3a211da2 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "required"
 DEPENDS = "makedevs"
 RDEPENDS = "makedevs"
 LICENSE = "GPL"
-PR = "r116"
+PR = "r117"
 
 SRC_URI = "file://functions \
            file://halt \