#RDEPENDS += "gnome-vfs-plugin-file"
#RRECOMMENDS += "gnome-vfs-plugin-http"
-PV = "0.8+svnr${SRCREV}"
+PV = "0.9+svnr${SRCREV}"
DEFAULT_PREFERENCE = "-1"
file://stock_contact.png \
file://stock_person.png \
file://contacts-owl-window-menu.patch;patch=1 \
- file://contacts-focus-avoidance.patch;patch=1 \
"
S = "${WORKDIR}/trunk"
+++ /dev/null
-Index: src/contacts-gtk.c
-===================================================================
---- a/src/contacts-gtk.c (revision 405)
-+++ b/src/contacts-gtk.c (working copy)
-@@ -426,7 +426,6 @@
- GTK_WIDGET_SET_FLAGS (edit_done_button, GTK_CAN_DEFAULT);
-
-
-- gtk_widget_grab_focus (search_entry);
- gtk_widget_grab_default (edit_button);
- gtk_window_add_accel_group (GTK_WINDOW (main_window), accel_group);
-
-@@ -436,8 +435,9 @@
- gtk_size_group_add_widget (size_group, summary_hbuttonbox);
- g_object_unref (size_group);
-
-+ /* Set it so no focus on the search box by default */
-+ gtk_window_set_focus (GTK_WINDOW (main_window), NULL);
-
--
- /* connect signals */
- g_signal_connect (G_OBJECT (main_window), "delete-event",
- G_CALLBACK (contacts_main_window_delete_event_cb), data);
-Index: src/contacts-edit-pane.c
-===================================================================
---- a/src/contacts-edit-pane.c (revision 405)
-+++ b/src/contacts-edit-pane.c (working copy)
-@@ -86,7 +86,7 @@
- if (data->ui->edit_button)
- gtk_window_set_default (window, data->ui->edit_button);
- if ((widget = data->ui->search_entry) && GTK_WIDGET_VISIBLE (widget))
-- gtk_window_set_focus (window, data->ui->search_entry);
-+ gtk_window_set_focus (window, NULL);
- }
-
- static void
-Index: trunk/src/contacts-gtk.c
+Index: contacts-0.9/src/contacts-gtk.c
===================================================================
---- trunk.orig/src/contacts-gtk.c 2007-07-11 22:16:08.000000000 +0100
-+++ trunk/src/contacts-gtk.c 2007-07-13 09:02:03.000000000 +0100
-@@ -179,8 +179,8 @@
+--- contacts-0.9.orig/src/contacts-gtk.c 2008-06-06 12:56:08.000000000 +0100
++++ contacts-0.9/src/contacts-gtk.c 2008-06-16 08:14:28.000000000 +0100
+@@ -220,8 +220,8 @@
vbox7 = gtk_vbox_new (FALSE, 0);
gtk_container_add (GTK_CONTAINER (main_window), vbox7);
+ main_menubar = gtk_menu_new ();
+ gtk_widget_show (main_menubar);
- contacts_menu = gtk_menu_item_new_with_mnemonic (_("_Contacts"));
+ contacts_menu = gtk_menu_item_new_with_mnemonic (_("C_ontacts"));
gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu);
-Index: trunk/src/Makefile.am
+Index: contacts-0.9/src/Makefile.am
===================================================================
---- trunk.orig/src/Makefile.am 2007-04-19 15:41:14.000000000 +0100
-+++ trunk/src/Makefile.am 2007-07-13 08:50:58.000000000 +0100
-@@ -28,7 +28,7 @@
+--- contacts-0.9.orig/src/Makefile.am 2008-06-03 09:16:56.000000000 +0100
++++ contacts-0.9/src/Makefile.am 2008-06-16 08:15:34.000000000 +0100
+@@ -40,7 +40,7 @@
contacts-@FRONTEND@.c \
contacts-@FRONTEND@.h
--contacts_LDADD = $(CONTACTS_LIBS)
-+contacts_LDADD = $(CONTACTS_LIBS) -lowl
- contacts_LDFLAGS = @CONTACTS_LIBS@
+-contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS)
++contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) -lowl
- MAINTAINERCLEANFILES = config.h.in Makefile.in
-Index: trunk/src/contacts-main.c
+ contacts_LDFLAGS = @CONTACTS_LIBS@ @DBUS_LIBS@
+
+Index: contacts-0.9/src/contacts-main.c
===================================================================
---- trunk.orig/src/contacts-main.c 2007-07-11 22:16:08.000000000 +0100
-+++ trunk/src/contacts-main.c 2007-07-13 09:02:30.000000000 +0100
+--- contacts-0.9.orig/src/contacts-main.c 2008-06-06 10:26:52.000000000 +0100
++++ contacts-0.9/src/contacts-main.c 2008-06-16 08:14:28.000000000 +0100
@@ -27,6 +27,8 @@
#include <libgnomevfs/gnome-vfs.h>
#endif
#include "bacon-message-connection.h"
#include "contacts-defs.h"
#include "contacts-utils.h"
-@@ -222,6 +224,10 @@
+@@ -266,6 +268,10 @@
gtk_widget_show_all (widget);
}