]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-wm-2 recipe
authorTomas Frydrych <tf@openedhand.com>
Fri, 21 Dec 2007 12:29:04 +0000 (12:29 +0000)
committerTomas Frydrych <tf@openedhand.com>
Fri, 21 Dec 2007 12:29:04 +0000 (12:29 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3368 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb [new file with mode: 0644]

diff --git a/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb b/meta/packages/matchbox-wm-2/matchbox-wm-2_svn.bb
new file mode 100644 (file)
index 0000000..1584f3d
--- /dev/null
@@ -0,0 +1,33 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Matchbox window manager"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxrender startup-notification expat gconf pango libxdamage libxcomposite"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager-2;proto=http \
+         "
+
+S = "${WORKDIR}/matchbox-window-manager-2"
+
+inherit autotools pkgconfig update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+FILES_${PN} = "${bindir}/* \
+               ${datadir}/matchbox-2 \
+               ${sysconfdir}/matchbox-2 \
+               ${datadir}/themes/*"
+
+EXTRA_OECONF =         "--enable-debug                 \
+                 --enable-compositing-manager  \
+               "
+
+do_install_append () {
+       cd ${D}${bindir}
+       ln -s matchbox-window-manager-2-simple matchbox-window-manager
+}