]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto-3.4: Disable extra slang header search path
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 Aug 2012 11:17:16 +0000 (12:17 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 Aug 2012 11:36:41 +0000 (12:36 +0100)
Add in a workaround to avoid host infection detection build failures
from the slang include directory in perf. I'll defer to Bruce to
fix this properly but we need a workaround now as this is breaking
builds.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto/noslang.patch [new file with mode: 0644]
meta/recipes-kernel/linux/linux-yocto_3.4.bb

diff --git a/meta/recipes-kernel/linux/linux-yocto/noslang.patch b/meta/recipes-kernel/linux/linux-yocto/noslang.patch
new file mode 100644 (file)
index 0000000..9cada34
--- /dev/null
@@ -0,0 +1,20 @@
+We (OE) install slang into /usr/include so we never need to look into 
+/usr/include/slang/. We never want to look into a hardcoded path like this
+since it triggers host infection issues. For now, simply remove this
+since it causes us problems.
+
+Upstream-Status: Pending (would need rework)
+
+Index: tools/perf/Makefile
+===================================================================
+--- linux.orig/tools/perf/Makefile     2012-08-07 10:29:43.020149620 +0000
++++ linux/tools/perf/Makefile  2012-08-07 10:30:08.128148098 +0000
+@@ -504,7 +504,7 @@
+               BASIC_CFLAGS += -DNO_NEWT_SUPPORT
+       else
+               # Fedora has /usr/include/slang/slang.h, but ubuntu /usr/include/slang.h
+-              BASIC_CFLAGS += -I/usr/include/slang
++              # BASIC_CFLAGS += -I/usr/include/slang
+               EXTLIBS += -lnewt -lslang
+               LIB_OBJS += $(OUTPUT)util/ui/setup.o
+               LIB_OBJS += $(OUTPUT)util/ui/browser.o
index 48333b3e00059835563c7f5b704f284612ff2227..5ab46b7a1e3e89e8a9f5f124879418bc328aa076 100644 (file)
@@ -20,6 +20,8 @@ SRCREV_meta ?= "7ff48aa47c50b6455d60ca93bc81260ce8fe1a1b"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
 
+SRC_URI += "file://noslang.patch"
+
 LINUX_VERSION ?= "3.4.6"
 
 PR = "${INC_PR}.0"