]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: chown hwdb.bin to root:root for do_rootfs
authorChristopher Larson <chris_larson@mentor.com>
Wed, 11 Nov 2015 05:34:01 +0000 (22:34 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Nov 2015 08:01:34 +0000 (08:01 +0000)
This is created by qemu for the do_rootfs case, which bypasses pseudo, so we
need to correct the ownership. This fixes a warning issued by
rootfs_check_host_user_contaminated.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_225.bb

index ea964131fb3e0c4dd14b348fe4a254e9c67d2e70..0e89d221a8df790053ea1b7c4acc2dbd12c66b17 100644 (file)
@@ -411,6 +411,7 @@ pkg_postinst_udev-hwdb () {
        if test -n "$D"; then
                ${@qemu_run_binary(d, '$D', '${base_bindir}/udevadm')} hwdb --update \
                        --root $D
+               chown root:root $D${sysconfdir}/udev/hwdb.bin
        else
                udevadm hwdb --update
        fi