]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-lib: Convert to use autotools_stage
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:52:39 +0000 (15:52 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 12 Jun 2009 14:52:39 +0000 (15:52 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/alsa/alsa-lib_1.0.20.bb

index d4bf79eb5ba9e5dd0821fda02d9e6dd1309ab36f..fe910ec59d9ea18d2afd559cf014326c54eb344e 100644 (file)
@@ -2,6 +2,7 @@ DESCRIPTION = "Alsa sound library"
 HOMEPAGE = "http://www.alsa-project.org"
 SECTION = "libs/multimedia"
 LICENSE = "GPL"
+PR = "r1"
 
 # configure.in sets -D__arm__ on the command line for any arm system
 # (not just those with the ARM instruction set), this should be removed,
@@ -12,22 +13,13 @@ ARM_INSTRUCTION_SET = "arm"
 SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
            file://fix-tstamp-declaration.patch;patch=1"
 
-inherit autotools pkgconfig
+inherit autotools_stage pkgconfig
 
 require alsa-fpu.inc
 EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
 
 EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
 
-do_stage () {
-       oe_libinstall -so -C src libasound ${STAGING_LIBDIR}/
-       install -d ${STAGING_INCDIR}/alsa/sound
-       install -m 0644 include/*.h ${STAGING_INCDIR}/alsa/
-       #install -m 0644 include/sound/ainstr*.h ${STAGING_INCDIR}/alsa/sound/
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 utils/alsa.m4 ${STAGING_DATADIR}/aclocal/
-}
-
 PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
 FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
 FILES_libasound = "${libdir}/libasound.so.*"