]> code.ossystems Code Review - openembedded-core.git/commitdiff
xorg-lib-common.inc: use REQUIRED_DISTRO_FEATURES variable
authorAndreas Oberritter <obi@opendreambox.org>
Thu, 5 Dec 2013 12:51:24 +0000 (13:51 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 9 Dec 2013 18:01:39 +0000 (18:01 +0000)
Convert custom DISTRO_FEATURES test to distro_features_check.bbclass,
and keep exceptions for libpciaccess and pixman.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb
meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb
meta/recipes-graphics/xorg-lib/xorg-lib-common.inc

index 6da86f24b66b66fc9230d3d3f1338a32757a55ff..d837bbd047d6aa90bda6bc48ef59a7a98a7e74e0 100644 (file)
@@ -10,3 +10,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=277aada5222b9a22fbf3471ff3687068"
 
 SRC_URI[md5sum] = "b7c0d3afce14eedca57312a3141ec13a"
 SRC_URI[sha256sum] = "abab8c2b050afb89bc29280e9c6b50ec5867174960d88bfb81a01036ec20de19"
+
+REQUIRED_DISTRO_FEATURES = ""
index d1f3df7f9c4d874ca7ebc7d90bf20359047c84c9..51cca5d13a5ed9d2f4b6d1d136880e0d626d6fdb 100644 (file)
@@ -33,3 +33,5 @@ SRC_URI += "\
 
 SRC_URI[md5sum] = "cdb566504fe9daf6728c7b03cc7ea228"
 SRC_URI[sha256sum] = "ae2bd664057e330d41b40336ed296d3512318ce7f2401cc42601f2613d371e4c"
+
+REQUIRED_DISTRO_FEATURES = ""
index 07b037330869e0cde85a12c19885f66a0f480ac1..231776a21c590a95b15c3e9347baffe7fcffb90e 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.bz2"
 
 S = "${WORKDIR}/${XORG_PN}-${PV}"
 
-inherit autotools pkgconfig
+inherit autotools distro_features_check pkgconfig
 
 EXTRA_OECONF = "--disable-specs --without-groff --without-ps2pdf --without-fop --without-xmlto"
 EXTRA_OECONF_append_libc-glibc = " --disable-malloc0returnsnull"
@@ -20,8 +20,4 @@ EXTRA_OECONF_append_libc-uclibc = " --enable-malloc0returnsnull"
 UNKNOWN_CONFIGURE_WHITELIST += "--enable-malloc0returnsnull --disable-malloc0returnsnull \
                                 --disable-specs --without-groff --without-ps2pdf --without-fop --without-xmlto"
 
-python () {
-        whitelist = [ "pixman", "libpciaccess" ]
-        if not d.getVar('BPN', True) in whitelist and not oe.utils.contains ('DISTRO_FEATURES', 'x11', True, False, d):
-                raise bb.parse.SkipPackage("'x11' not in DISTRO_FEATURES")
-}
+REQUIRED_DISTRO_FEATURES ?= "x11"