]> code.ossystems Code Review - openembedded-core.git/commitdiff
oh-puzzles: added SVN version
authorMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 2 Apr 2007 16:00:08 +0000 (16:00 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Mon, 2 Apr 2007 16:00:08 +0000 (16:00 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1420 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/puzzles/files/game.png [moved from meta/packages/puzzles/puzzles/game.png with 100% similarity]
meta/packages/puzzles/oh-puzzles_svn.bb [new file with mode: 0644]

diff --git a/meta/packages/puzzles/oh-puzzles_svn.bb b/meta/packages/puzzles/oh-puzzles_svn.bb
new file mode 100644 (file)
index 0000000..7a9a52b
--- /dev/null
@@ -0,0 +1,43 @@
+DESCRIPTION = "Portable Puzzle Collection"
+LICENSE = "MIT"
+SECTION = "x11"
+DEPENDS = "gtk+"
+PV = "0.1+svn${SRCDATE}"
+
+inherit autotools pkgconfig
+
+SRC_URI = "svn://svn.o-hand.com/repos/;module=oh-puzzles;proto=http \
+           file://game.png"
+
+S = "${WORKDIR}/${PN}"
+
+do_install_append () {
+    mv ${D}${bindir} ${D}/usr/games
+
+    install -d ${D}/${datadir}/applications/
+    install -d ${D}/${datadir}/pixmaps/
+
+    install ${WORKDIR}/game.png ${D}/${datadir}/pixmaps/
+
+    cd ${D}/${prefix}/games
+    for prog in *; do
+       if [ -x $prog ]; then
+           echo "making ${D}/${datadir}/applications/$prog.desktop"
+           cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
+[Desktop Entry]
+Encoding=UTF-8
+Name=$prog
+Exec=${prefix}/games/$prog
+Icon=game.png
+Terminal=false
+Type=Application
+Categories=Game
+StartupNotify=true
+SingleInstance=true
+STOP
+        fi
+    done
+}
+
+FILES_${PN} += "/usr/games/*"
+FILES_${PN}-dbg += "/usr/games/.debug/*"