]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-xorg: upgrade to 1.13.0
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 15 Nov 2012 11:07:10 +0000 (13:07 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Nov 2012 16:48:27 +0000 (16:48 +0000)
The patch contains several aditional changes:
 * removed one backported patch (included in the new release);
 * changed mips64-compiler.patch to apply properly;
 * licence checksum for COPYING file changed: some copyright years have
   been changed;
 * bump PR in xorg-driver-common.inc so that all input/video drivers
   get rebuilt. That's becaue the ABI changed;

The following external modules are now built-in:
 * DBE
 * DRI2
 * DRI
 * RECORD

The extmod module was completely removed.

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/machine/include/ia32-base.inc
meta/recipes-graphics/xorg-driver/xorg-driver-common.inc
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/mips64-compiler.patch [deleted file]
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/pkgconfig-deps.patch [deleted file]
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/crosscompile.patch [moved from meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/crosscompile.patch with 100% similarity]
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/fix_open_max_preprocessor_error.patch [moved from meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/fix_open_max_preprocessor_error.patch with 100% similarity]
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/macro_tweak.patch [moved from meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/macro_tweak.patch with 100% similarity]
meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/mips64-compiler.patch [new file with mode: 0644]
meta/recipes-graphics/xorg-xserver/xserver-xorg.inc
meta/recipes-graphics/xorg-xserver/xserver-xorg_1.13.0.bb [moved from meta/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb with 56% similarity]

index 4b10183c212f3db93f842572ce25b676b13b2ba9..c2d267aa3bb6125dcf5b3d67b8a1ca10c4afdf45 100644 (file)
@@ -33,11 +33,8 @@ XSERVER_IA32_BASE = "xserver-xorg \
            xf86-input-synaptics \
            "
 
-XSERVER_IA32_EXT = "xserver-xorg-extension-dri \
-           xserver-xorg-extension-dri2 \
+XSERVER_IA32_EXT = "
            xserver-xorg-extension-glx \
-           xserver-xorg-extension-extmod \
-           xserver-xorg-extension-dbe \
            xserver-xorg-module-libint10 \
            "
 
index d2c9a5f4532f31d4ca37a14821c313c7166432ed..aabf86b95ccfb9d43cee8dc070ef6f837fff0e31 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "x11/drivers"
 LICENSE = "MIT-X"
 
 PE = "2"
-INC_PR = "r19"
+INC_PR = "r20"
 
 DEPENDS = "virtual/xserver xproto randrproto util-macros"
 
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/mips64-compiler.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/mips64-compiler.patch
deleted file mode 100644 (file)
index e6bc95b..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-on mips64/n64 pointers are 64bit therefore the pointer conversions to int dont work well
-so we end up with incompatible conversion errors
-
-This patch choses the right values for mips64
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-Upstream-Status: Pending
-Index: xorg-server-1.11.2/hw/xfree86/common/compiler.h
-===================================================================
---- xorg-server-1.11.2.orig/hw/xfree86/common/compiler.h       2012-05-10 12:19:59.485599046 -0700
-+++ xorg-server-1.11.2/hw/xfree86/common/compiler.h    2012-05-10 12:20:53.109602488 -0700
-@@ -104,6 +104,7 @@
- #  if !defined(__arm__)
- #   if !defined(__sparc__) && !defined(__sparc) && !defined(__arm32__) && !defined(__nds32__) \
-+      && !defined(__mips64) \
-       && !(defined(__alpha__) && defined(linux)) \
-       && !(defined(__ia64__) && defined(linux)) \
-@@ -708,7 +709,7 @@
- }
- #   elif defined(__mips__) || (defined(__arm32__) && !defined(__linux__))
--#    ifdef __arm32__
-+#    if defined (__arm32__) || defined (__mips64)
- #     define PORT_SIZE long
- #    else
- #     define PORT_SIZE short
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/pkgconfig-deps.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.11.4/pkgconfig-deps.patch
deleted file mode 100644 (file)
index fee8d76..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-Upstream-Status: Backport
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-commit 41d903918a5721e53ed694880eab44170f9717cc
-Author: Jeremy Huddleston <jeremyhu@apple.com>
-Date:   Wed Sep 14 13:45:18 2011 -0500
-
-    xorg-server.pc.in: Remove libpciaccess and pixman-1 from Requires
-    
-    Every module building against xorg-server does not *Require* pixman nor
-    libpciaccess.  If such modules need pixman or pciaccess, they should be
-    depending on them directly rather than inheriting a dependency from
-    xorg-server.  To do this, they should use PKG_CHECK_MODULES in configure.ac
-    to check for pixman-1 or pciaccess and include the apporpriate _LIBS variable
-    to the appropriate _LDFLAGS variable in Makefile.am
-    
-    This also moves pixman-1 to Requires.private, so CPPFLAGS is set right to
-    to satisfy include dependencies but avoid linking needlessly.
-    
-    Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
-    Reviewed-by: Gaetan Nadon <memsize@videotron.ca>
-
-diff --git a/configure.ac b/configure.ac
-index 50beb01..4bfa82c 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -780,11 +780,6 @@ VIDMODEPROTO="xf86vidmodeproto >= 2.2.99.1"
- WINDOWSWMPROTO="windowswmproto"
- APPLEWMPROTO="applewmproto >= 1.4"
--dnl Core modules for most extensions, et al.
--SDK_REQUIRED_MODULES="[xproto >= 7.0.22] [randrproto >= 1.2.99.3] [renderproto >= 0.11] [xextproto >= 7.1.99] [inputproto >= 1.9.99.902] [kbproto >= 1.0.3] fontsproto"
--# Make SDK_REQUIRED_MODULES available for inclusion in xorg-server.pc
--AC_SUBST(SDK_REQUIRED_MODULES)
--
- dnl List of libraries that require a specific version
- LIBAPPLEWM="applewm >= 1.4"
- LIBDMX="dmx >= 1.0.99.1"
-@@ -806,6 +801,11 @@ dnl specific modules against it
- PKG_CHECK_MODULES(PIXMAN, $LIBPIXMAN)
- REQUIRED_LIBS="$REQUIRED_LIBS $LIBPIXMAN $LIBXFONT xau"
-+dnl Core modules for most extensions, et al.
-+SDK_REQUIRED_MODULES="[xproto >= 7.0.22] [randrproto >= 1.2.99.3] [renderproto >= 0.11] [xextproto >= 7.1.99] [inputproto >= 1.99.99.902] [kbproto >= 1.0.3] fontsproto $LIBPIXMAN"
-+# Make SDK_REQUIRED_MODULES available for inclusion in xorg-server.pc
-+AC_SUBST(SDK_REQUIRED_MODULES)
-+
- REQUIRED_MODULES="[fixesproto >= 5.0] [damageproto >= 1.1] [xcmiscproto >= 1.2.0] [xtrans >= 1.2.2] [bigreqsproto >= 1.1.0] $SDK_REQUIRED_MODULES"
- if test "x$CONFIG_UDEV" = xyes &&
-@@ -1583,6 +1583,7 @@ if test "x$XORG" = xyes; then
-       if test "x$PCI" = xyes; then
-       PKG_CHECK_MODULES([PCIACCESS], $LIBPCIACCESS)
-+      SDK_REQUIRED_MODULES="$SDK_REQUIRED_MODULES $LIBPCIACCESS"
-       SAVE_LIBS=$LIBS
-       SAVE_CFLAGS=$CFLAGS
-       CFLAGS=$PCIACCESS_CFLAGS
-diff --git a/xorg-server.pc.in b/xorg-server.pc.in
-index fb238b5..a98eca8 100644
---- a/xorg-server.pc.in
-+++ b/xorg-server.pc.in
-@@ -15,7 +15,6 @@ abi_extension=@abi_extension@
- Name: xorg-server
- Description: Modular X.Org X Server
- Version: @PACKAGE_VERSION@
--Requires: pixman-1 pciaccess
- Requires.private: @SDK_REQUIRED_MODULES@
- Cflags: -I${sdkdir} @symbol_visibility@
- Libs: -L${libdir}
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/mips64-compiler.patch b/meta/recipes-graphics/xorg-xserver/xserver-xorg-1.13.0/mips64-compiler.patch
new file mode 100644 (file)
index 0000000..168368e
--- /dev/null
@@ -0,0 +1,29 @@
+on mips64/n64 pointers are 64bit therefore the pointer conversions to int dont work well
+so we end up with incompatible conversion errors
+
+This patch choses the right values for mips64
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: xorg-server-1.13.0/hw/xfree86/common/compiler.h
+===================================================================
+--- xorg-server-1.13.0-orig/hw/xfree86/common/compiler.h       2012-06-14 23:04:29.000000000 +0300
++++ xorg-server-1.13.0/hw/xfree86/common/compiler.h    2012-11-08 10:06:50.865831783 +0200
+@@ -101,6 +101,7 @@
+ #if defined(NO_INLINE) || defined(DO_PROTOTYPES)
+ #if !defined(__arm__)
+ #if !defined(__sparc__) && !defined(__sparc) && !defined(__arm32__) && !defined(__nds32__) \
++      && !defined(__mips64) \
+       && !(defined(__alpha__) && defined(linux)) \
+       && !(defined(__ia64__) && defined(linux)) \
+@@ -721,7 +722,7 @@
+ }
+ #elif defined(__mips__) || (defined(__arm32__) && !defined(__linux__))
+-#ifdef __arm32__
++#if defined (__arm32__) || defined (__mips64)
+ #define PORT_SIZE long
+ #else
+ #define PORT_SIZE short
index 33564eb66ed302df7675f259a614474c425902f6..4135a8b4cff2778cb131192b5a48f0e1b58c7a26 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "The X.Org X server"
 HOMEPAGE = "http://www.x.org"
 SECTION = "x11/base"
 LICENSE = "MIT-X"
-LIC_FILES_CHKSUM = "file://COPYING;md5=74df27b6254cc88d2799b5f4f5949c00"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bc098b9774ed096943f6c37b5beeef13"
 
 # xf86-*-* packages depend on an X server built with the xfree86 DDX
 # so we have a virtual to represent that:
@@ -13,7 +13,7 @@ PROVIDES = "virtual/xserver-xf86"
 PROVIDES += "virtual/xserver"
 
 PE = "2"
-INC_PR = "r3"
+INC_PR = "r5"
 
 XORG_PN = "xorg-server"
 SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
@@ -48,12 +48,7 @@ PACKAGES =+ "${PN}-security-policy \
              ${PN}-utils \
              ${PN}-xephyr \
              ${PN}-multimedia-modules \
-             ${PN}-extension-dri \
-             ${PN}-extension-dri2 \
              ${PN}-extension-glx \
-             ${PN}-extension-record \
-             ${PN}-extension-extmod \
-             ${PN}-extension-dbe \
              ${PN}-module-libint10 \
              ${PN}-module-libafb \
              ${PN}-module-libwfb  \
@@ -67,6 +62,24 @@ PACKAGES =+ "${PN}-security-policy \
 RRECOMMENDS_${PN} += "${PN}-security-policy xkeyboard-config rgb xserver-xf86-config"
 RDEPENDS_${PN}-xvfb += "xkeyboard-config"
 RDEPENDS_${PN}-module-exa = "${PN} (= ${EXTENDPKGV})"
+RREPLACES_${PN} =  "${PN}-extension-dri \
+                    ${PN}-extension-dri2 \
+                    ${PN}-extension-record \
+                    ${PN}-extension-extmod \
+                    ${PN}-extension-dbe \
+                   "
+RPROVIDES_${PN} =  "${PN}-extension-dri \
+                    ${PN}-extension-dri2 \
+                    ${PN}-extension-record \
+                    ${PN}-extension-extmod \
+                    ${PN}-extension-dbe \
+                   "
+RCONFLICTS_${PN} = "${PN}-extension-dri \
+                    ${PN}-extension-dri2 \
+                    ${PN}-extension-record \
+                    ${PN}-extension-extmod \
+                    ${PN}-extension-dbe \
+                   "
 
 FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/modules/*.so ${libdir}/xorg/modules/*.so /etc/X11 ${libdir}/xorg/protocol.txt ${datadir}/X11/xorg.conf.d"
 FILES_${PN}-dev += "${libdir}/xorg/modules/*.la ${libdir}/xorg/modules/*/*.la"
@@ -82,12 +95,7 @@ FILES_${PN}-xvfb = "${bindir}/Xvfb"
 FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
 FILES_${PN}-xephyr = "${bindir}/Xephyr"
 FILES_${PN}-multimedia-modules = "${libdir}/xorg/modules/multimedia/*drv*"
-FILES_${PN}-extension-dri = "${libdir}/xorg/modules/extensions/libdri.so"
-FILES_${PN}-extension-dri2 = "${libdir}/xorg/modules/extensions/libdri2.so"
 FILES_${PN}-extension-glx = "${libdir}/xorg/modules/extensions/libglx.so"
-FILES_${PN}-extension-record = "${libdir}/xorg/modules/extensions/librecord.so"
-FILES_${PN}-extension-extmod = "${libdir}/xorg/modules/extensions/libextmod.so"
-FILES_${PN}-extension-dbe = "${libdir}/xorg/modules/extensions/libdbe.so"
 FILES_${PN}-module-libint10 = "${libdir}/xorg/modules/libint10.so"
 FILES_${PN}-module-libafb = "${libdir}/xorg/modules/libafb.so"
 FILES_${PN}-module-libwfb = "${libdir}/xorg/modules/libwfb.so"
similarity index 56%
rename from meta/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb
rename to meta/recipes-graphics/xorg-xserver/xserver-xorg_1.13.0.bb
index 4739ee2b7bb7508bc9db612009b8bc68bec4b1a9..8ad87b862a65d84f50ff4d291d133d237b079619 100644 (file)
@@ -4,10 +4,9 @@ require xserver-xorg.inc
 SRC_URI += "file://crosscompile.patch \
             file://fix_open_max_preprocessor_error.patch \
             file://mips64-compiler.patch \
-            file://pkgconfig-deps.patch \
            "
 
-SRC_URI[md5sum] = "256325e9b17dff479d92bed97f6b0adb"
-SRC_URI[sha256sum] = "3e2935bc400612df58d5b5e6840829e2c63af02c2e7d2893092500358a4366fc"
+SRC_URI[md5sum] = "bde3d178b756597d2ec2a19ef60d2e1f"
+SRC_URI[sha256sum] = "548b91cb01087ad4f892428e7ac4955251cf12393e86c70420436b33848ef28a"
 
 PR = "${INC_PR}.0"