]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-testtools: add it for oeqa
authorRobert Yang <liezhi.yang@windriver.com>
Fri, 27 Jul 2018 07:36:17 +0000 (15:36 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 30 Jul 2018 11:44:28 +0000 (12:44 +0100)
- It is required by oeqa, add it so that we can add nativesdk-python3-testtools
  to buildtools-tarball.
- The original one is python-testtools_2.3.0.bb which is from meta-openstack
  layer, I divided it into python-testtools.inc and python3-testtools_2.2.0.bb,
  and extended to nativesdk.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-testtools.inc [new file with mode: 0644]
meta/recipes-devtools/python/python3-testtools_2.2.0.bb [new file with mode: 0644]

diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
new file mode 100644 (file)
index 0000000..fe1d49a
--- /dev/null
@@ -0,0 +1,27 @@
+SUMMARY = "Extensions to the Python standard library unit testing framework"
+HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
+
+inherit pypi
+
+SRC_URI[md5sum] = "adef817b07ba24fd6d807fd41a4f1ef4"
+SRC_URI[sha256sum] = "80f606607a6e4ce4d0e24e5b786562aa42c581906f3c070607a4265f3da65810"
+
+DEPENDS += " \
+    ${PYTHON_PN}-pbr \
+    "
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+    ${PYTHON_PN}-pbr-native \
+    "
+
+RDEPENDS_${PN} += "\
+    ${PYTHON_PN}-extras \
+    ${PYTHON_PN}-pbr \
+    ${PYTHON_PN}-six \
+    "
+
+BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-testtools_2.2.0.bb b/meta/recipes-devtools/python/python3-testtools_2.2.0.bb
new file mode 100644 (file)
index 0000000..896ecee
--- /dev/null
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-testtools.inc