]> code.ossystems Code Review - openembedded-core.git/commitdiff
ghostscript: disable libidn support
authorKang Kai <kai.kang@windriver.com>
Mon, 3 Sep 2012 07:53:12 +0000 (15:53 +0800)
committerSaul Wold <sgw@linux.intel.com>
Tue, 4 Sep 2012 05:52:56 +0000 (22:52 -0700)
If libidn is just populated to sysroot but rpm packages are not created,
build ghostscript will check libidn automatically and then depends on
libidn. But package libidn doesn't exist, so build image which contains
ghostscript will fail with:

| error: Failed dependencies:
|  libidn11 >= 1.25 is needed by ghostscript-9.05-r2.i586
|  libidn.so.11(LIBIDN_1.0) is needed by ghostscript-9.05-r2.i586
|  libidn.so.11 is needed by ghostscript-9.05-r2.i586

Disable libidn support to fix this issue.

Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/ghostscript/ghostscript_9.05.bb

index dc6e481515dc1b8c65031391ba3cc37367b1d7c3..1c18b217daa7a7b901e89672f7317cbec5af7c16 100644 (file)
@@ -15,7 +15,7 @@ SECTION = "console/utils"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=c5326026692dbed183f0558f926580f8"
 
-PR = "r2"
+PR = "r3"
 
 DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
 DEPENDS_virtclass-native = ""
@@ -36,7 +36,7 @@ SRC_URI[md5sum] = "f7c6f0431ca8d44ee132a55d583212c1"
 SRC_URI[sha256sum] = "593f77f7584704bdf9de41598a084a4208c3ad3b940a1de1faaf8f59a15cc207"
 
 EXTRA_OECONF = "--without-x --with-system-libtiff --without-jbig2dec --without-jasper \
-                --with-fontpath=${datadir}/fonts --with-install-cups"
+                --with-fontpath=${datadir}/fonts --with-install-cups --without-libidn"
 
 # This has been fixed upstream but for now we need to subvert the check for time.h
 # http://bugs.ghostscript.com/show_bug.cgi?id=692443