]> code.ossystems Code Review - openembedded-core.git/commitdiff
documentation/adt-manual/Makefile: Initial Makefile
authorScott Rifenbark <scott.m.rifenbark@intel.com>
Mon, 14 Mar 2011 20:43:26 +0000 (14:43 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2011 13:38:02 +0000 (13:38 +0000)
These edits take the Makefile from the version I copied over from
the Kernel manual to create the initial version for the ADT Manual.

Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
documentation/adt-manual/Makefile

index dcfcb92312238183df1ed1d189f10a7d5dcd6263..ec19bce9cdcc833311c6933ba08a76534a899c3b 100644 (file)
@@ -14,7 +14,7 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
 all: html pdf tarball
 
 pdf:
-       ../tools/poky-docbook-to-pdf kernel-manual.xml ../template
+       ../tools/poky-docbook-to-pdf adt-manual.xml ../template
 
 ##
 # These URI should be rewritten by your distribution's xml catalog to
@@ -23,16 +23,16 @@ pdf:
 html:
 #       See http://www.sagehill.net/docbookxsl/HtmlOutput.html 
 
-#      xsltproc $(XSLTOPTS) -o yocto-project-qs.html $(XSL_XHTML_URI) yocto-project-qs.xml
-       xsltproc $(XSLTOPTS) -o kernel-manual.html yocto-project-kernel-manual-customization.xsl kernel-manual.xml
+#      xsltproc $(XSLTOPTS) -o adt-manual.html $(XSL_XHTML_URI) adt-manual.xml
+       xsltproc $(XSLTOPTS) -o adt-manual.html adt-manual-customization.xsl adt-manual.xml
 
 tarball: html
-       tar -cvzf kernel-manual.tgz kernel-manual.html style.css figures/kernel-title.png figures/kernel-big-picture.png figures/kernel-architecture-overview.png
+       tar -cvzf adt-manual.tgz adt-manual.html style.css figures/adt-title.png figures/yocto-project-transp.png
 
 validate:
-       xmllint --postvalid --xinclude --noout kernel-manual.xml
+       xmllint --postvalid --xinclude --noout adt-manual.xml
 
-OUTPUTS = kernel-manual.tgz kernel-manual.html kernel-manual.pdf
+OUTPUTS = adt-manual.tgz adt-manual.html adt-manual.pdf
 SOURCES = *.png *.xml *.css
 
 publish: