]> code.ossystems Code Review - openembedded-core.git/commitdiff
slang: add PREMIRRORS to handle upstream moving tarballs
authorRoss Burton <ross.burton@intel.com>
Mon, 31 Oct 2016 15:45:58 +0000 (15:45 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 6 Nov 2016 23:35:15 +0000 (23:35 +0000)
The slang maintainer only puts the current release at
jedsoft.org/releases/slang/slang-1.2.3.tar.bz2, all previous releases are moved
into /releases/slang/old/.

As this breaks the fetch the moment a new version is released, use PREMIRRORS to
also look in the /old/ directory.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/slang/slang_2.3.0.bb

index 17efbbe223dbc6e31a2d9c5d008b1ee52df7db84..ce7b16a8f7e28633f56e55b45bec42443780d049 100644 (file)
@@ -22,6 +22,7 @@ SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \
            file://0001-Fix-error-conflicting-types-for-posix_close.patch \
           "
 UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/"
+PREMIRRORS_append = "\n http://www.jedsoft.org/releases/slang/.* http://www.jedsoft.org/releases/slang/old/ \n"
 
 inherit autotools-brokensep