]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: use PACKAGECONFIG instead of DISTRO_FEATURES to define EGL_PLATFORMS
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 12 Jun 2013 23:19:55 +0000 (01:19 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Jun 2013 11:40:52 +0000 (12:40 +0100)
* it makes it easier to change PACKAGECONFIG in .bbappend and get
  consistent EGL_PLATFORMS

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/mesa/mesa.inc

index ec303018405930876d5286666e5585f96eaa7fea..cc117531c7582600775a95448f1ada69f401b10d 100644 (file)
@@ -42,8 +42,8 @@ EXTRA_OECONF += "--enable-gbm"
 PACKAGECONFIG[gles] = "--enable-gles1 --enable-gles2, --disable-gles1 --disable-gles2"
 
 EGL_PLATFORMS  = "drm"
-EGL_PLATFORMS .="${@base_contains('DISTRO_FEATURES', 'x11', ',x11', '', d)}"
-EGL_PLATFORMS .="${@base_contains('DISTRO_FEATURES', 'wayland', ',wayland', '', d)}"
+EGL_PLATFORMS .="${@base_contains('PACKAGECONFIG', 'x11', ',x11', '', d)}"
+EGL_PLATFORMS .="${@base_contains('PACKAGECONFIG', 'wayland', ',wayland', '', d)}"
 PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=${EGL_PLATFORMS}, --disable-egl"
 
 # Multiple virtual/gl providers being built breaks staging