]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-rp: added armv7a fix from linux-omap to make qemuarmv7 build
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 22 Jul 2008 11:26:05 +0000 (11:26 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 22 Jul 2008 11:26:05 +0000 (11:26 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4926 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/linux/linux-rp-2.6.26/fixes.patch [new file with mode: 0644]
meta/packages/linux/linux-rp_2.6.26.bb

diff --git a/meta/packages/linux/linux-rp-2.6.26/fixes.patch b/meta/packages/linux/linux-rp-2.6.26/fixes.patch
new file mode 100644 (file)
index 0000000..5df21d5
--- /dev/null
@@ -0,0 +1,38 @@
+Index: git/arch/arm/Makefile
+===================================================================
+--- git.orig/arch/arm/Makefile 2008-06-13 13:10:59.000000000 +0100
++++ git/arch/arm/Makefile      2008-07-19 10:31:31.000000000 +0100
+@@ -47,7 +47,7 @@
+ # Note that GCC does not numerically define an architecture version
+ # macro, but instead defines a whole series of macros which makes
+ # testing for a specific architecture or later rather impossible.
+-arch-$(CONFIG_CPU_32v7)               :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7a,-march=armv5t -Wa$(comma)-march=armv7a)
++arch-$(CONFIG_CPU_32v7)               :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7-a,-march=armv5t -Wa$(comma)-march=armv7-a)
+ arch-$(CONFIG_CPU_32v6)               :=-D__LINUX_ARM_ARCH__=6 $(call cc-option,-march=armv6,-march=armv5t -Wa$(comma)-march=armv6)
+ # Only override the compiler option if ARMv6. The ARMv6K extensions are
+ # always available in ARMv7
+Index: git/include/asm-arm/processor.h
+===================================================================
+--- git.orig/include/asm-arm/processor.h       2008-06-13 13:12:19.000000000 +0100
++++ git/include/asm-arm/processor.h    2008-07-19 10:31:31.000000000 +0100
+@@ -109,14 +109,16 @@
+ #if __LINUX_ARM_ARCH__ >= 5
+ #define ARCH_HAS_PREFETCH
+-static inline void prefetch(const void *ptr)
++#define prefetch(ptr) __builtin_prefetch(ptr)
++
++/*static inline void prefetch(const void *ptr)
+ {
+       __asm__ __volatile__(
+-              "pld\t%0"
++              "pld\ta%0"
+               :
+-              : "o" (*(char *)ptr)
++              : "p" (ptr)
+               : "cc");
+-}
++}*/
+ #define ARCH_HAS_PREFETCHW
+ #define prefetchw(ptr)        prefetch(ptr)
index a2f264761adb4801ee70af9afe867efc3bc06b1a..04e0ff4d0d12b9b663d132ed4ac02d81aa424eec 100644 (file)
@@ -1,6 +1,6 @@
 require linux-rp.inc
 
-PR = "r7"
+PR = "r8"
 
 DEFAULT_PREFERENCE = "-1"
 DEFAULT_PREFERENCE_qemuarm = "1"
@@ -56,6 +56,7 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.25.tar.bz2 \
            file://versatile-armv6.patch;patch=1 \
           file://cpufreq-fix.patch;patch=1 \
           file://zaurus-i2c-init.patch;patch=1 \
+          file://fixes.patch;patch=1 \
            file://defconfig-c7x0 \
            file://defconfig-hx2000 \
            file://defconfig-akita \