]> code.ossystems Code Review - openembedded-core.git/commitdiff
oprofile: Add 0.9.2
authorRichard Purdie <richard@openedhand.com>
Thu, 12 Oct 2006 10:10:19 +0000 (10:10 +0000)
committerRichard Purdie <richard@openedhand.com>
Thu, 12 Oct 2006 10:10:19 +0000 (10:10 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@793 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oprofile/oprofile-0.9.2/opcontrol_bashisms.patch [new file with mode: 0644]
meta/packages/oprofile/oprofile_0.9.2.bb [new file with mode: 0644]

diff --git a/meta/packages/oprofile/oprofile-0.9.2/opcontrol_bashisms.patch b/meta/packages/oprofile/oprofile-0.9.2/opcontrol_bashisms.patch
new file mode 100644 (file)
index 0000000..01ef11d
--- /dev/null
@@ -0,0 +1,16 @@
+ utils/opcontrol |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: oprofile-0.9.2/utils/opcontrol
+===================================================================
+--- oprofile-0.9.2.orig/utils/opcontrol        2006-03-29 22:54:07.000000000 +0100
++++ oprofile-0.9.2/utils/opcontrol     2006-10-12 11:14:39.000000000 +0100
+@@ -485,7 +485,7 @@ validate_separate_args()
+       SEPARATE_KERNEL=0
+       SEPARATE_THREAD=0
+       SEPARATE_CPU=0
+-      while (($i < $#)); do
++      while [ "$i" -lt "$#" ]; do
+               shift
+               case "$1" in
+                       lib|library)
diff --git a/meta/packages/oprofile/oprofile_0.9.2.bb b/meta/packages/oprofile/oprofile_0.9.2.bb
new file mode 100644 (file)
index 0000000..e64aa10
--- /dev/null
@@ -0,0 +1,39 @@
+SECTION = "devel"
+DESCRIPTION = "OProfile is a system-wide profiler for Linux systems, capable \
+of profiling all running code at low overhead."
+LICENSE = "GPL"
+DEPENDS = "popt binutils"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
+          file://no_arm_mapping_syms.patch;patch=1 \
+           file://opcontrol_bashisms.patch;patch=1 \
+          file://acinclude.m4"
+S = "${WORKDIR}/oprofile-${PV}"
+
+inherit autotools
+
+# NOTE: this disables the build of the kernel modules.
+# Should add the oprofile kernel modules, for those with 2.4
+# kernels, as a seperate .oe file.
+EXTRA_OECONF = "--with-kernel-support \
+               --without-x"
+
+do_configure () {
+       cp ${WORKDIR}/acinclude.m4 ${S}/
+       autotools_do_configure
+}
+# Available config options
+#  --enable-abi                 enable abi portability code (default is disabled)
+#  --enable-pch                 enable precompiled header (default is disabled)
+#  --enable-gcov                enable option for gcov coverage testing (default is disabled)
+#  --disable-werror            disable -Werror flag (default is enabled for non-release)
+#  --disable-optimization      disable optimization flags (default is enabled)
+#  --with-kernel-support        Use 2.6 kernel (no kernel source tree required)
+#  --with-linux=dir             Path to Linux source tree
+#  --with-module-dir=dir        Path to module installation directory
+#  --with-extra-includes=DIR    add extra include paths
+#  --with-extra-libs=DIR        add extra library paths
+#  --with-x                use the X Window System
+#  --with-qt-dir           where the root of Qt is installed
+#  --with-qt-includes      where the Qt includes are.
+#  --with-qt-libraries     where the Qt library is installed.