]> code.ossystems Code Review - openembedded-core.git/commitdiff
depmodwrapper-cross/qemuwrapper-cross: Drop unneeded binutils dependency
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 19 Feb 2017 14:57:00 +0000 (06:57 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Feb 2017 20:29:12 +0000 (12:29 -0800)
By default these pull in binutils-cross since they're a cross tool
and pull in any native tool requirements. In reality they don't
need such tools at build time or runtime since they're scripts.

Therefore clear the dependency and save on some processing time.

(From OE-Core rev: 63796765122e2eee2b78930797d571acb5c244d1)

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
meta/recipes-kernel/kmod/depmodwrapper-cross_1.0.bb

index b86400bd27ef39195103d258e07f54fb3bb21a65..e40cdafc94d7655595afd6d5d269a634dc2bd0f7 100644 (file)
@@ -7,6 +7,8 @@ DEPENDS += "qemu-native"
 
 inherit qemu
 
+do_populate_sysroot[depends] = ""
+
 do_install () {
        install -d ${D}${bindir_crossscripts}/
 
index aa2805b035bcf707072489e1c2403a0ed6dad7b1..17a99a4afba119e6cfa0a1ab70425c41f3274283 100644 (file)
@@ -11,6 +11,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 SSTATE_SCAN_FILES += "depmodwrapper"
 EXTRA_STAGING_FIXMES = "PKGDATA_DIR"
 
+do_populate_sysroot[depends] = ""
+
 do_install() {
        install -d ${D}${bindir_crossscripts}/