]> code.ossystems Code Review - openembedded-core.git/commitdiff
readline: Fix RPATH Warnings for GPLv2
authorSaul Wold <sgw@linux.intel.com>
Wed, 21 Mar 2012 22:54:34 +0000 (15:54 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Mar 2012 23:08:51 +0000 (23:08 +0000)
the norpath.patch with v2 and it worked correctly?
WARNING: QA Issue: readline: /work/i586-poky-linux/readline-5.2-r7/packages-split/readline/usr/lib/libhistory.so.5.2 contains probably-redundant RPATH /usr/lib
WARNING: QA Issue: readline: /work/i586-poky-linux/readline-5.2-r7/packages-split/readline/usr/lib/libreadline.so.5.2 contains probably-redundant RPATH /usr/lib
WARNING: QA Issue: readline: /work/i586-poky-linux/readline-5.2-r7/packages-split/readline/usr/lib/libreadline.so.5 contains probably-redundant RPATH /usr/lib
WARNING: QA Issue: readline: /work/i586-poky-linux/readline-5.2-r7/packages-split/readline/usr/lib/libhistory.so.5 contains probably-redundant RPATH /usr/lib

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch [new file with mode: 0644]
meta/recipes-core/readline/readline-6.2/norpath.patch [moved from meta/recipes-core/readline/files/norpath.patch with 100% similarity]
meta/recipes-core/readline/readline_5.2.bb

diff --git a/meta/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch b/meta/recipes-core/readline/readline-5.2/fix-redundant-rpath.patch
new file mode 100644 (file)
index 0000000..3166b47
--- /dev/null
@@ -0,0 +1,21 @@
+This support script ends up hardcoding unnecessary rpaths into the libraries. We
+will search $libdir automatically so this is just wastes space. There may be some
+cases this is necessary but our use cases aren't one of them.
+
+Upstream-Status: Inappropriate
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: readline-5.2/support/shobj-conf
+===================================================================
+--- readline-5.2.orig/support/shobj-conf
++++ readline-5.2/support/shobj-conf
+@@ -110,7 +110,7 @@ linux*-*|gnu*-*|k*bsd*-gnu-*)
+       SHOBJ_LD='${CC}'
+       SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
+-      SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir) -Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
++      SHLIB_XLDFLAGS='-Wl,-soname,`basename $@ $(SHLIB_MINOR)`'
+       SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)$(SHLIB_MINOR)'
+       ;;
index bf64853484d25b8e697570b77140be5ef13fdc28..705c526d047bc9767988b91cfb76595a874afad1 100644 (file)
@@ -9,11 +9,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=03b36fdd84f74b8d8189a202b980b67f"
 
 DEPENDS += "ncurses"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "${GNU_MIRROR}/readline/${BPN}-${PV}.tar.gz \
            file://configure-fix.patch \
-           file://acinclude.m4"
+           file://acinclude.m4 \
+           file://fix-redundant-rpath.patch"
 
 SRC_URI[md5sum] = "e39331f32ad14009b9ff49cc10c5e751"
 SRC_URI[sha256sum] = "12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45"