]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston: Fix parallel make race
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Aug 2015 16:47:31 +0000 (17:47 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 9 Aug 2015 07:12:42 +0000 (00:12 -0700)
The current approach used by the Makefile ends up installing
weston.desktop twice and can give build failures when using
parallel make flags. Change to just have one DATA reference.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/wayland/weston/parallelmake.patch [new file with mode: 0644]
meta/recipes-graphics/wayland/weston_1.8.0.bb

diff --git a/meta/recipes-graphics/wayland/weston/parallelmake.patch b/meta/recipes-graphics/wayland/weston/parallelmake.patch
new file mode 100644 (file)
index 0000000..34d7512
--- /dev/null
@@ -0,0 +1,22 @@
+The current approach used by the Makefile ends up installing 
+weston.desktop twice and can give build failures when using 
+parallel make flags. Change to just have one DATA reference.
+
+RP
+2015/8/3
+Upstream-Status: Pending
+
+Index: weston-1.8.0/Makefile.am
+===================================================================
+--- weston-1.8.0.orig/Makefile.am
++++ weston-1.8.0/Makefile.am
+@@ -179,8 +179,7 @@ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = src/weston.pc
+ wayland_sessiondir = $(datadir)/wayland-sessions
+-wayland_session_DATA = src/weston.desktop
+-dist_wayland_session_DATA = $(wayland_session_DATA)
++dist_wayland_session_DATA = src/weston.desktop
+ westonincludedir = $(includedir)/weston
+ westoninclude_HEADERS =                               \
index ac6bd9784b4358606c4a7f67452b9622bf49b68a..342c604b98519bed2251103bda5bde1c660cbb10 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
            file://make-lcms-explicitly-configurable.patch \
            file://make-libwebp-explicitly-configurable.patch \
            file://0001-make-error-portable.patch \
+           file://parallelmake.patch \
 "
 SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
 SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"