]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes-core: replace virtclass-native(sdk) with class-native(sdk)
authorRobert Yang <liezhi.yang@windriver.com>
Sat, 27 Oct 2012 08:48:17 +0000 (16:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 2 Nov 2012 16:15:29 +0000 (16:15 +0000)
The overrides virtclass-native and virtclass-nativesdk are deprecated,
which should be replaced by class-native and class-nativesdk.

[YOCTO #3297]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
20 files changed:
meta/recipes-core/coreutils/coreutils_6.9.bb
meta/recipes-core/coreutils/coreutils_8.14.bb
meta/recipes-core/dbus/dbus-glib.inc
meta/recipes-core/dbus/dbus.inc
meta/recipes-core/eglibc/eglibc-initial.inc
meta/recipes-core/eglibc/eglibc.inc
meta/recipes-core/eglibc/eglibc_2.16.bb
meta/recipes-core/gettext/gettext_0.16.1.bb
meta/recipes-core/gettext/gettext_0.18.1.1.bb
meta/recipes-core/glib-2.0/glib-2.0_2.32.4.bb
meta/recipes-core/glib-2.0/glib.inc
meta/recipes-core/jpeg/jpeg_8d.bb
meta/recipes-core/libxml/libxml2.inc
meta/recipes-core/ncurses/ncurses.inc
meta/recipes-core/uclibc/uclibc-initial_0.9.33.bb
meta/recipes-core/uclibc/uclibc-initial_git.bb
meta/recipes-core/uclibc/uclibc_0.9.33.bb
meta/recipes-core/uclibc/uclibc_git.bb
meta/recipes-core/util-linux/util-linux.inc
meta/recipes-core/util-linux/util-linux_2.21.2.bb

index 20d812093077cf88202ef32842bf666ed3fd5d74..ffdd2af8c5d333ca537b772aa15781b37061219b 100644 (file)
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
                     file://src/ls.c;startline=4;endline=16;md5=482a96d4f25010a4e13f8743e0c3685e"
 PR = "r3"
 DEPENDS = "coreutils-native-${PV}"
-DEPENDS_virtclass-native = "gettext-native"
+DEPENDS_class-native = "gettext-native"
 
 inherit autotools gettext
 
@@ -28,7 +28,7 @@ SRC_URI_BASE = "${GNU_MIRROR}/coreutils/${BP}.tar.bz2 \
            "
 
 SRC_URI = "${SRC_URI_BASE} file://fix_for_manpage_building.patch"
-SRC_URI_virtclass-native = "${SRC_URI_BASE}"
+SRC_URI_class-native = "${SRC_URI_BASE}"
 
 SRC_URI[md5sum] = "c9607d8495f16e98906e7ed2d9751a06"
 SRC_URI[sha256sum] = "89c2895ad157de50e53298b22d91db116ee4e1dd3fdf4019260254e2e31497b0"
index 178bd674c6847a8e1e5c18467a582f1195cc4f4f..3f58cfdadc7d22007abff317a77614e38ed99ff7 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
                     file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
 PR = "r5"
 DEPENDS = "gmp libcap"
-DEPENDS_virtclass-native = ""
+DEPENDS_class-native = ""
 
 inherit autotools gettext
 
@@ -21,7 +21,7 @@ SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.xz \
 SRC_URI[md5sum] = "bcb135ce553493a45aba01b39eb3920a"
 SRC_URI[sha256sum] = "0d120817c19292edb19e92ae6b8eac9020e03d51e0af9cb116cf82b65d18b02d"
 
-EXTRA_OECONF_virtclass-native = "--without-gmp"
+EXTRA_OECONF_class-native = "--without-gmp"
 
 # [ df mktemp base64 gets a special treatment and is not included in this
 bindir_progs = "basename chcon cksum comm csplit cut dir dircolors dirname du \
index 3469a4f2b10d20158c716a5d62b195ce0841e406..dff30c75647f10edf66d069d19d4f7a02c811000 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=cf5b3a2f7083750d504333114e738656 \
 SECTION = "base"
 
 DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
-DEPENDS_virtclass-native = "glib-2.0-native dbus-native"
+DEPENDS_class-native = "glib-2.0-native dbus-native"
 
 SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
            file://no-examples.patch \
@@ -24,7 +24,7 @@ PACKAGECONFIG[tests] = "--enable-tests,,,"
 
 EXTRA_OECONF = "--with-introspect-xml=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml \
                 --with-dbus-binding-tool=${STAGING_BINDIR_NATIVE}/dbus-binding-tool"
-EXTRA_OECONF_virtclass-native = "--with-introspect-xml=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml"
+EXTRA_OECONF_class-native = "--with-introspect-xml=${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml"
 
 PACKAGES += "${PN}-bash-completion ${PN}-tests-dbg ${PN}-tests"
 
index 550eb0ab3b931050a8247d088e524857c66e5e80..d165cdd8782feb1687807ea5d4a611a49238c50c 100644 (file)
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
                     file://dbus/dbus.h;firstline=6;endline=20;md5=6eea2e0c7750dd8e620dcb1437312fa5"
 X11DEPENDS = "virtual/libx11 libsm"
 DEPENDS = "expat virtual/libintl ${@base_contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
-DEPENDS_virtclass-native = "expat-native virtual/libintl-native"
-DEPENDS_virtclass-nativesdk = "nativesdk-expat virtual/nativesdk-libintl virtual/libx11"
+DEPENDS_class-native = "expat-native virtual/libintl-native"
+DEPENDS_class-nativesdk = "nativesdk-expat virtual/nativesdk-libintl virtual/libx11"
 
 INC_PR = "r5"
 
@@ -34,7 +34,7 @@ DEBIANNAME_${PN} = "dbus-1"
 PACKAGES =+ "${PN}-lib ${PN}-systemd"
 
 OLDPKGNAME = "dbus-x11"
-OLDPKGNAME_virtclass-nativesdk = ""
+OLDPKGNAME_class-nativesdk = ""
 
 # for compatibility
 RPROVIDES_${PN} = "${OLDPKGNAME}"
@@ -64,7 +64,7 @@ pkg_postinst_dbus() {
 }
 
 EXTRA_OECONF_X = "${@base_contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
-EXTRA_OECONF_X_virtclass-native = "--without-x --disable-x11-autolaunch"
+EXTRA_OECONF_X_class-native = "--without-x --disable-x11-autolaunch"
 
 EXTRA_OECONF = "--disable-tests \
                 --disable-checks \
@@ -105,7 +105,7 @@ do_install() {
        ln -sf /dev/null ${D}/${systemd_unitdir}/system/dbus-1.service
 }
 
-do_install_virtclass-native() {
+do_install_class-native() {
        autotools_do_install
 
        # for dbus-glib-native introspection generation
@@ -117,7 +117,7 @@ do_install_virtclass-native() {
        ./bus/dbus-daemon --introspect > ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml
 }
 
-do_install_virtclass-nativesdk() {
+do_install_class-nativesdk() {
        autotools_do_install
 }
 BBCLASSEXTEND = "native nativesdk"
index 1520efd7189e70ff4256ffdc7083fcbb455606ae..c1a090e39e2f721d740c822187d8da9c78ef9171 100644 (file)
@@ -7,7 +7,7 @@ PACKAGES = ""
 PACKAGES_DYNAMIC = ""
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
 
 do_configure () {
index e1ec6b2b8cd914e239e2c3ea4c848fe7d0e86b76..3d136bf8d763ef41c0acf3ba50a874499fe1dd17 100644 (file)
@@ -3,7 +3,7 @@ require eglibc-ld.inc
 require eglibc-testing.inc
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
 
 TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TCBOOTSTRAP}"
@@ -39,7 +39,7 @@ CACHED_CONFIGUREVARS += "ac_cv_path_KSH=${base_bindir}/bash \
                       "
 
 GLIBC_EXTRA_OECONF ?= ""
-GLIBC_EXTRA_OECONF_virtclass-nativesdk = ""
+GLIBC_EXTRA_OECONF_class-nativesdk = ""
 INHIBIT_DEFAULT_DEPS = "1"
 
 ARM_INSTRUCTION_SET = "arm"
@@ -68,4 +68,4 @@ do_configure_append() {
 
 GLIBC_ADDONS ?= "ports,nptl,libidn"
 SDK_GLIBC_ADDONS ?= "ports,nptl,libidn"
-GLIBC_ADDONS_virtclass-nativesdk = "${SDK_GLIBC_ADDONS}"
+GLIBC_ADDONS_class-nativesdk = "${SDK_GLIBC_ADDONS}"
index 56a0a381927e1e610c90266480d1f1d6d30a4852..aa9256cdc170bd25ec4d5a3ff28d529eb429b55c 100644 (file)
@@ -37,7 +37,7 @@ LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
       file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
       file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
 
-SRC_URI_append_virtclass-nativesdk = " file://ld-search-order.patch \
+SRC_URI_append_class-nativesdk = " file://ld-search-order.patch \
             file://relocatable_sdk.patch \
             "
 S = "${WORKDIR}/eglibc-${PV}/libc"
index 00045d55605cd8802634b88ccd4852cb70065bdd..db8314b02cac30ed9f79c4ccbac2ae6600f2a0e8 100644 (file)
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9ea3144f04c41cd2eada5d3f472e6ea5"
 
 PR = "r6"
 DEPENDS = "virtual/libiconv"
-DEPENDS_virtclass-native = ""
+DEPENDS_class-native = ""
 PROVIDES = "virtual/libintl virtual/gettext"
-PROVIDES_virtclass-native = ""
+PROVIDES_class-native = ""
 
 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
            file://gettext-vpath.patch \
index 0f6f0685c62c46e2fabab43c3ff4b47b1bc45c6e..c3265e1a22e846b41d12109a38ee3979bf5b8b3a 100644 (file)
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 PR = "r18"
 DEPENDS = "gettext-native virtual/libiconv ncurses expat"
-DEPENDS_virtclass-native = "gettext-minimal-native"
+DEPENDS_class-native = "gettext-minimal-native"
 PROVIDES = "virtual/libintl virtual/gettext"
-PROVIDES_virtclass-native = "virtual/gettext-native"
+PROVIDES_class-native = "virtual/gettext-native"
 RCONFLICTS_${PN} = "proxy-libintl"
 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
           file://parallel.patch \
@@ -100,7 +100,7 @@ do_install_append() {
     rm -f ${D}${libdir}/preloadable_libintl.so
 }
 
-do_install_append_virtclass-native () {
+do_install_append_class-native () {
        rm ${D}${datadir}/aclocal/*
        rm ${D}${datadir}/gettext/config.rpath
        rm ${D}${datadir}/gettext/po/Makefile.in.in
index 10c0b615ed91a07e5c73b03c672bcae6161e95db..22c6c7bef0cffb0ac32fad90874d51d8d314bb5e 100644 (file)
@@ -4,8 +4,8 @@ PR = "r6"
 PE = "1"
 
 DEPENDS += "libffi python-argparse-native zlib"
-DEPENDS_virtclass-native += "libffi-native python-argparse-native"
-DEPENDS_virtclass-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
+DEPENDS_class-native += "libffi-native python-argparse-native"
+DEPENDS_class-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
 
 SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
 
@@ -19,7 +19,7 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
 SRC_URI[md5sum] = "bf84fefd9c1a5b5a7a38736f4ddd674a"
 SRC_URI[sha256sum] = "a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b167fae2"
 
-SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
+SRC_URI_append_class-native = " file://glib-gettextize-dir.patch"
 BBCLASSEXTEND = "native nativesdk"
 
 do_configure_prepend() {
index 8b099f223e09feb13e795fed5a167478748066ce..6e2b5d2a74850edb401a079cdfd41f9f9f854e01 100644 (file)
@@ -14,8 +14,8 @@ BUGTRACKER = "http://bugzilla.gnome.org"
 SECTION = "libs"
 
 DEPENDS = "glib-2.0-native zip virtual/libiconv"
-DEPENDS_virtclass-native = "pkgconfig-native gettext-native"
-DEPENDS_virtclass-nativesdk = "nativesdk-libtool"
+DEPENDS_class-native = "pkgconfig-native gettext-native"
+DEPENDS_class-nativesdk = "nativesdk-libtool"
 PACKAGES =+ "${PN}-utils ${PN}-bash-completion ${PN}-codegen"
 
 LEAD_SONAME = "libglib-2.0.*"
@@ -28,7 +28,7 @@ S = "${WORKDIR}/glib-${PV}"
 CORECONF = "--disable-dtrace --disable-fam --disable-libelf --disable-systemtap"
 
 EXTRA_OECONF = "--enable-included-printf=no ${CORECONF}"
-EXTRA_OECONF_virtclass-native = "${CORECONF}"
+EXTRA_OECONF_class-native = "${CORECONF}"
 EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no ${CORECONF}"
 
 FILES_${PN} = "${libdir}/lib*${SOLIBS} ${datadir}/glib-2.0/schemas \
index 67816198ddbe92f7a517a57ee2eb90aa506d7ead..eba5bf46d28a1a80b1850c7cba4c7c99065aaefc 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://README;md5=4f46756b064c225fae088903300e5c98"
 SECTION = "libs"
 
 DEPENDS = "libtool-cross"
-DEPENDS_virtclass-native = "libtool-native"
+DEPENDS_class-native = "libtool-native"
 
 PR = "r1"
 
index 68437ae949910cef1876b7a88faf54da8ad86e84..9ec507bad99aec952a02cd1bf9f6c37b2f5ec83d 100644 (file)
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=bb90c48926316d9af6e2d70ca7013ade \
                     file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
                     file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
 
-DEPENDS_virtclass-native = "python-native"
+DEPENDS_class-native = "python-native"
 DEPENDS =+ "zlib"
 
 SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
@@ -25,8 +25,8 @@ do_configure_prepend () {
 }
 
 EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-lzma"
-EXTRA_OECONF_virtclass-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
-EXTRA_OECONF_virtclass-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
+EXTRA_OECONF_class-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
+EXTRA_OECONF_class-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
 EXTRA_OECONF_linuxstdbase = "--without-python --with-debug --with-legacy --with-catalog --with-docbook --with-c14n --without-lzma"
 
 # required for pythong binding
index cce080d402a432ccfe123312b54b7cbf4573dcfd..24b19c7d136af36ce3594fe1c42b7eb86d74d921 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://ncurses/base/version.c;beginline=1;endline=27;md5=cbc180a8c44ca642e97c35452fab5f66"
 SECTION = "libs"
 DEPENDS = "ncurses-native"
-DEPENDS_virtclass-native = ""
+DEPENDS_class-native = ""
 INC_PR = "r12"
 
 inherit autotools binconfig multilib_header
@@ -27,7 +27,7 @@ ENABLE_WIDEC ?= "true"
 BUILD_CPPFLAGS += "-D_GNU_SOURCE"
 
 # natives don't generally look in base_libdir
-base_libdir_virtclass-native = "${libdir}"
+base_libdir_class-native = "${libdir}"
 
 # Helper function for do_configure to allow multiple configurations
 # $1 the directory to run configure in
index 211d530d70c03310ba293e8329b46cfa63377b1a..22f56de1c27daefdf6da5247d8e7a1d66936ae53 100644 (file)
@@ -9,7 +9,7 @@ PACKAGES = ""
 PACKAGES_DYNAMIC = ""
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 
 do_install() {
        # Install initial headers into the cross dir
index 6fd75299c513709ec7596a8eeef3c8b8c5ccd63f..c0b7d52f60653a33f5f4e4dfa453ddfc29b9a669 100644 (file)
@@ -9,7 +9,7 @@ PACKAGES = ""
 PACKAGES_DYNAMIC = ""
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 
 do_install() {
        # Install initial headers into the cross dir
index 8deedd3708ef0a22b1f93984a5ea7e78db4918e3..4071d2adad63782aa016037175ad9c7e4c13abbe 100644 (file)
@@ -5,7 +5,7 @@ require uclibc-package.inc
 require uclibc-${PV}.inc
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 
 DEPENDS = "virtual/${TARGET_PREFIX}binutils \
            virtual/${TARGET_PREFIX}gcc-initial \
index e8a6d68523e83ecf86f2a7493ff0df7afebe8f79..a66656dfecf8866412de39cf75247a3e7a0eb8da 100644 (file)
@@ -3,7 +3,7 @@ require uclibc-package.inc
 require uclibc-git.inc
 
 STAGINGCC = "gcc-cross-initial"
-STAGINGCC_virtclass-nativesdk = "gcc-crosssdk-initial"
+STAGINGCC_class-nativesdk = "gcc-crosssdk-initial"
 
 PROVIDES += "virtual/libc virtual/${TARGET_PREFIX}libc-for-gcc"
 
index d62d406b3b4a3ddcb1ce81b798621867457fbf48..f2f9a046bb791f831a39ada7d2b248f02fdcb241 100644 (file)
@@ -17,7 +17,7 @@ LIC_FILES_CHKSUM = "file://README.licensing;md5=9c920d811858a74b67a36ba23cbaa95f
 
 inherit autotools gettext pkgconfig
 DEPENDS = "zlib ncurses"
-DEPENDS_append_virtclass-native = " lzo-native"
+DEPENDS_append_class-native = " lzo-native"
 
 SRC_URI = "${KERNELORG_MIRROR}/linux/utils/util-linux/v${MAJOR_VERSION}/util-linux-${PV}.tar.bz2 \
            file://MCONFIG \
@@ -73,8 +73,8 @@ RREPLACES_util-linux-blkid = "e2fsprogs-blkid"
 RDEPENDS_${PN} = "util-linux-umount util-linux-swaponoff util-linux-losetup"
 RRECOMMENDS_${PN} = "util-linux-fdisk util-linux-cfdisk util-linux-sfdisk util-linux-mount util-linux-readprofile util-linux-mkfs "
 
-RRECOMMENDS_${PN}_virtclass-native = ""
-RDEPENDS_${PN}_virtclass-native = ""
+RRECOMMENDS_${PN}_class-native = ""
+RDEPENDS_${PN}_class-native = ""
 
 do_compile () {
        set -e
index e64ebe97ac1275171c43ea4f189adf2a0155f154..24bed2707cf6645ee214c5091e99d3f34bae5b86 100644 (file)
@@ -40,4 +40,4 @@ do_remove_lscpu() {
 addtask remove_lscpu before do_configure after do_patch
 
 CACHED_CONFIGUREVARS += "scanf_cv_alloc_modifier=as"
-EXTRA_OECONF_virtclass-native += "--disable-fallocate --disable-use-tty-group"
+EXTRA_OECONF_class-native += "--disable-fallocate --disable-use-tty-group"