]> code.ossystems Code Review - openembedded-core.git/commitdiff
automake: Add missing libtool tag for cppasm language
authorKhem Raj <raj.khem@gmail.com>
Thu, 27 Jul 2017 04:18:51 +0000 (21:18 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 9 Aug 2017 08:24:02 +0000 (09:24 +0100)
This is highlighted when CC is passing flags like -fPIE
which are stripped by libtool when building shared libs
and replaced with -fPIC, this actually results in CC
not matching the CC computed from cmdline created for
compiling and as a result libtool heuristic to compute
tags auotmatically fails.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch [new file with mode: 0644]
meta/recipes-devtools/automake/automake_1.15.1.bb

diff --git a/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch b/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch
new file mode 100644 (file)
index 0000000..1221f13
--- /dev/null
@@ -0,0 +1,27 @@
+From 25a8ac30486798d23f516722d73eb622e6264f28 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 26 Jul 2017 11:19:56 -0700
+Subject: [PATCH] automake: Add default libtool_tag to cppasm.
+
+    * bin/automake.in (register_language): Define default libtool tag to be CC
+    since CPPASCOMPILE is using CC to call assembler
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ bin/automake.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: automake-1.15.1/bin/automake.in
+===================================================================
+--- automake-1.15.1.orig/bin/automake.in
++++ automake-1.15.1/bin/automake.in
+@@ -831,6 +831,7 @@ register_language ('name' => 'cppasm',
+                  'compiler' => 'CPPASCOMPILE',
+                  'compile_flag' => '-c',
+                  'output_flag' => '-o',
++                 'libtool_tag' => 'CC',
+                  'extensions' => ['.S', '.sx']);
+ # Fortran 77
index 481234185ef10bc25731d31dbd2abf153c74aae6..4f9b616b6649155781edd25354f8e20a17e089ff 100644 (file)
@@ -24,6 +24,7 @@ SRC_URI += "file://python-libdir.patch \
             file://performance.patch \
             file://new_rt_path_for_test-driver.patch \
             file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
+            file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
             "
 
 SRC_URI[md5sum] = "95df3f2d6eb8f81e70b8cb63a93c8853"