]> code.ossystems Code Review - openembedded-core.git/commitdiff
libdrm: Explicitly disable the cairo dependency
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Oct 2012 11:46:05 +0000 (11:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Oct 2012 13:50:48 +0000 (14:50 +0100)
We don't want the cairo dependency. Unfortunately simply checking whether its present
isn't good enough. If its not in DEPENDS, it can disappear half way through building.
We therefore need to explictly disable it.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/drm/libdrm.inc
meta/recipes-graphics/drm/libdrm/nocairo.patch [new file with mode: 0644]
meta/recipes-graphics/drm/libdrm_2.4.39.bb

index cc0979107047884de475b5c1ee1553123bc7e756..2ed9c14b1dd2f5f66f5a6b7c05a418a072152f6a 100644 (file)
@@ -18,6 +18,8 @@ DEPENDS += " libpciaccess"
 
 inherit autotools pkgconfig
 
+EXTRA_OECONF += "--disable-cairo"
+
 PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-kms"
 FILES_${PN}-tests = "${bindir}/dr* ${bindir}/mode*"
 FILES_${PN}-drivers = "${libdir}/libdrm_*.so.*"
diff --git a/meta/recipes-graphics/drm/libdrm/nocairo.patch b/meta/recipes-graphics/drm/libdrm/nocairo.patch
new file mode 100644 (file)
index 0000000..f9b7f3a
--- /dev/null
@@ -0,0 +1,39 @@
+We don't want the cairo dependency. Unfortunately simply checking whether its present 
+isn't good enough. If its not in DEPENDS, it can disappear half way through building.
+We therefore need to explictly disable it.
+
+RP
+2012/10/5
+
+Index: libdrm-2.4.39/configure.ac
+===================================================================
+--- libdrm-2.4.39.orig/configure.ac    2012-08-24 14:54:42.000000000 +0000
++++ libdrm-2.4.39/configure.ac 2012-10-05 11:37:52.484821221 +0000
+@@ -63,6 +63,11 @@
+             [Disable KMS mm abstraction library (default: auto)]),
+             [LIBKMS=$enableval], [LIBKMS=auto])
++AC_ARG_ENABLE(cairo,
++            AS_HELP_STRING([--disable-cairo],
++            [Disable cairo (default: auto)]),
++            [ENABLECAIRO=$enableval], [ENABLECAIRO=auto])
++
+ AC_ARG_ENABLE(intel,
+             AS_HELP_STRING([--disable-intel],
+             [Enable support for intel's KMS API (default: auto)]),
+@@ -201,9 +206,12 @@
+       AC_DEFINE(HAVE_EXYNOS, 1, [Have EXYNOS support])
+ fi
+-PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
+-if test "x$HAVE_CAIRO" = xyes; then
+-      AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
++HAVE_CAIRO=no
++if test "x$ENABLECAIRO" = xyes; then
++      PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
++      if test "x$HAVE_CAIRO" = xyes; then
++              AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
++      fi
+ fi
+ AM_CONDITIONAL(HAVE_CAIRO, [test "x$HAVE_CAIRO" = xyes])
index 4e6a8d56c6e80c50fc18f2f840bd377e35c569f0..cb1f7f99fcb18697d7092d56e3f0803b89adb3eb 100644 (file)
@@ -4,6 +4,7 @@ PR = "${INC_PR}.0"
 
 SRC_URI += "file://installtests.patch \
             file://GNU_SOURCE_definition.patch \
+            file://nocairo.patch \
            "
 
 SRC_URI[md5sum] = "9a299e021d81bab6c82307582c78319d"