]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: install populate-extfs.sh
authorMartin Jansa <martin.jansa@gmail.com>
Tue, 28 Apr 2015 22:46:18 +0000 (00:46 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2015 10:39:47 +0000 (11:39 +0100)
* install populate-extfs.sh from contrib, be aware that in order
  to use it you need to set DEBUGFS shell variable, otherwise it will
  try to use debugfs from relative path which is almost always
  incorrect:
    CONTRIB_DIR=$(dirname $(readlink -f $0))
    DEBUGFS="$CONTRIB_DIR/../debugfs/debugfs"

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb

index 67a5ea74f29809df36fecb796b106fd353439958..be1db9e89e439118708c477e3137232e2fbf93e8 100644 (file)
@@ -54,6 +54,8 @@ do_install () {
        oe_multilib_header ext2fs/ext2_types.h
        install -d ${D}${base_bindir}
        mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
+
+       install -v -m 755 ${S}/contrib/populate-extfs.sh ${D}${base_sbindir}/
 }
 
 do_install_append_class-target() {