]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo: adjust for attr 2.4.48
authorAlexander Kanavin <alex.kanavin@gmail.com>
Tue, 14 Jan 2020 13:59:54 +0000 (14:59 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 Jan 2020 22:21:31 +0000 (22:21 +0000)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pseudo/files/0006-xattr-adjust-for-attr-2.4.48-release.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_git.bb

diff --git a/meta/recipes-devtools/pseudo/files/0006-xattr-adjust-for-attr-2.4.48-release.patch b/meta/recipes-devtools/pseudo/files/0006-xattr-adjust-for-attr-2.4.48-release.patch
new file mode 100644 (file)
index 0000000..161357d
--- /dev/null
@@ -0,0 +1,48 @@
+From 93d95ed2eaedcca110c214e1fe3f8896b1f6f853 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Tue, 17 Dec 2019 20:24:27 +0100
+Subject: [PATCH] xattr: adjust for attr 2.4.48 release
+
+Latest versions of attr have removed the xattr.h header,
+with the rationale that libc is providing the same wrappers.
+
+attr/attributes.h is providing the ENOATTR definition.
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ ports/linux/subports         | 5 +++--
+ ports/linux/xattr/portdefs.h | 3 ++-
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/ports/linux/subports b/ports/linux/subports
+index 2c43ac9..740ec83 100755
+--- a/ports/linux/subports
++++ b/ports/linux/subports
+@@ -29,11 +29,12 @@ fi
+ if    $port_xattr; then
+       cat > dummy.c <<EOF
+ #include <sys/types.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
++#include <attr/attributes.h>
+ int i;
+ EOF
+       if ! ${CC} -c -o dummy.o dummy.c >/dev/null 2>&1; then
+-              echo >&2 "Warning: Can't compile trivial program using <attr/xattr.h>".
++              echo >&2 "Warning: Can't compile trivial program using <attr/attributes.h>".
+               echo >&2 "         xattr support will require that header."
+       fi
+       echo "linux/xattr"
+diff --git a/ports/linux/xattr/portdefs.h b/ports/linux/xattr/portdefs.h
+index 56cd3ca..068d39a 100644
+--- a/ports/linux/xattr/portdefs.h
++++ b/ports/linux/xattr/portdefs.h
+@@ -2,5 +2,6 @@
+  * SPDX-License-Identifier: LGPL-2.1-only
+  *
+  */
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
++#include <attr/attributes.h>
+ #include <stdint.h>
index 7c75293ef177c9a4d26c9e196b9995b231da5002..d921d85a05c18d4946c1cd1c3203277b3ce7b925 100644 (file)
@@ -9,6 +9,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo \
            file://0001-maketables-wrappers-use-Python-3.patch \
            file://0001-Add-statx.patch \
            file://0001-realpath.c-Remove-trailing-slashes.patch \
+           file://0006-xattr-adjust-for-attr-2.4.48-release.patch \
            "
 
 SRCREV = "060058bb29f70b244e685b3c704eb0641b736f73"