]> code.ossystems Code Review - openembedded-core.git/commitdiff
ltp/posix: replace CWD with PWD
authorJackie Huang <jackie.huang@windriver.com>
Mon, 12 Dec 2016 05:59:47 +0000 (13:59 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 17 Dec 2016 09:56:41 +0000 (09:56 +0000)
Backport a patch to replace CWD with PWD to avoid
error messages in test results:

basename: missing operand
Try 'basename --help' for more information.

(From OE-Core rev: 8665ccb5c3cefca43898caea06198e79504fdeff)

Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/ltp/ltp/0038-run-posix-option-group-test-replace-CWD-qith-PWD.patch [new file with mode: 0644]
meta/recipes-extended/ltp/ltp_20160126.bb

diff --git a/meta/recipes-extended/ltp/ltp/0038-run-posix-option-group-test-replace-CWD-qith-PWD.patch b/meta/recipes-extended/ltp/ltp/0038-run-posix-option-group-test-replace-CWD-qith-PWD.patch
new file mode 100644 (file)
index 0000000..8034152
--- /dev/null
@@ -0,0 +1,44 @@
+From f356775c400f40e3803d80a7bd295b4265959c45 Mon Sep 17 00:00:00 2001
+From: Vineet Gupta <Vineet.Gupta1@synopsys.com>
+Date: Mon, 29 Feb 2016 14:34:40 +0530
+Subject: [PATCH] run-posix-option-group-test: replace CWD qith PWD
+
+When running LTP Open Posix Testsuite there is lot of messages as:
+
+| Usage: basename FILE [SUFFIX]
+|
+| Strip directory path and .SUFFIX from FILE
+|
+| *******************
+| Testing
+| *******************
+
+This is because there is no $CWD defined in shell and it looks like $PWD
+was intended instead.
+
+Signed-off-by: Vineet Gupta <vgupta@synopsys.com>
+Signed-off-by: Cyril Hrubis <chrubis@suse.cz>
+
+Upstream-Status: Backport
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ testcases/open_posix_testsuite/bin/run-tests.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testcases/open_posix_testsuite/bin/run-tests.sh b/testcases/open_posix_testsuite/bin/run-tests.sh
+index d4bd988..5ee5687 100755
+--- a/testcases/open_posix_testsuite/bin/run-tests.sh
++++ b/testcases/open_posix_testsuite/bin/run-tests.sh
+@@ -29,7 +29,7 @@ run_test_loop() {
+       cat <<EOF
+ *******************
+-Testing $(basename $CWD)
++Testing $(basename $PWD)
+ *******************
+ $(printf "PASS\t\t%3d" $NUM_PASS)
+ $(printf "FAIL\t\t%3d" $NUM_FAIL)
+-- 
+2.7.4
+
index 841302b0ad000e30ae13647ace2e85f82aaefab3..6e2ceac0e20d6432040fe27d2ca6e4372784da67 100644 (file)
@@ -64,6 +64,7 @@ SRC_URI = "git://github.com/linux-test-project/ltp.git \
            file://0035-fix-test_proc_kill-hang.patch \
            file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
            file://0037-containers-netns_netlink-Avoid-segmentation-fault.patch \
+           file://0038-run-posix-option-group-test-replace-CWD-qith-PWD.patch \
            "
 
 S = "${WORKDIR}/git"