]> code.ossystems Code Review - openembedded-core.git/commitdiff
patch to allow the moblin proto to run without shader support
authorTomas Frydrych <tf@openedhand.com>
Sat, 4 Oct 2008 06:02:58 +0000 (06:02 +0000)
committerTomas Frydrych <tf@openedhand.com>
Sat, 4 Oct 2008 06:02:58 +0000 (06:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5414 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch [new file with mode: 0644]
meta/packages/clutter/moblin-proto_git.bb

diff --git a/meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch b/meta/packages/clutter/moblin-proto/fix-shader-and-callbacks.patch
new file mode 100644 (file)
index 0000000..4a3eddb
--- /dev/null
@@ -0,0 +1,44 @@
+diff --git a/Makefile b/Makefile
+index e05b5b7..c348a1e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -64,7 +64,7 @@ HFILES  = $(wildcard *.h)
+ %.o: %.c $(HFILES)
+       $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
+ $(BINARY): $(OBJECTS)
+-      $(CXX) -o $@ $(OBJECTS) $(LIBS)
++      $(CXX) -rdynamic -o $@ $(OBJECTS) $(LIBS)
+ #$(BINARY): $(CFILES)
+ #     $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
+diff --git a/moblin-desktop.c b/moblin-desktop.c
+index 6dd4f2c..fb9d231 100644
+--- a/moblin-desktop.c
++++ b/moblin-desktop.c
+@@ -103,6 +103,8 @@ void moblin_blur (void)
+   if (desktop->maincopy)
+     return;
++  if (clutter_feature_available (CLUTTER_FEATURE_SHADERS_GLSL))
++    {
+ #if 0
+   desktop->maincopy = clutter_texture_new_from_actor (desktop->mainstuff);
+ #else
+@@ -158,6 +160,17 @@ void moblin_blur (void)
+                                     1.0f / moblin_desktop_width ());
+   }
+  clutter_actor_set_shader_param (desktop->maincopy, "radius", 3.0);
++    }
++  else
++    {
++      ClutterColor clr= { 0x44, 0x44, 0x44, 0x77 };
++      guint w, h;
++
++      desktop->maincopy = clutter_rectangle_new_with_color (&clr);
++      clutter_actor_get_size (desktop->mainstuff, &w, &h);
++      clutter_actor_set_size (desktop->maincopy, w, h);
++      clutter_group_add (desktop->copyholder, desktop->maincopy);
++    }
+ }
+ void moblin_unblur (void)
index 8ce97bbeabd5fad148132289d76248afc4f55d50..c56b8ba6c33c3c6cafa99637a80b7987fcf56561 100644 (file)
@@ -1,10 +1,11 @@
 DEPENDS = "clutter-box2d"
 
 PV = "0.0+git${SRCREV}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \
-           file://paths.patch;patch=1"
+           file://paths.patch;patch=1 \
+          file://fix-shader-and-callbacks.patch;patch=1"
 
 S = "${WORKDIR}/git"