]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm_5.4.0: Fix configuration issue with native/nativesdk
authorMark Hatle <mark.hatle@windriver.com>
Fri, 23 Dec 2011 01:01:37 +0000 (19:01 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Dec 2011 17:32:28 +0000 (17:32 +0000)
RPM's configuration assumes if the prefix isn't /usr or /usr/local
that you really want the DB in $prefix/var -- we want it in
$localstatedir.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.0.bb

index 2c0c076ebdd48ce43e251242ddc97cc428818e14..122d3a922a7c53c3ffca853d0f2e1a7028395230 100644 (file)
@@ -45,7 +45,7 @@ LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 DEPENDS = "bzip2 zlib db openssl elfutils expat libpcre attr acl popt ${extrarpmdeps}"
 extrarpmdeps = "python perl"
 extrarpmdeps_virtclass-native = "file-native"
-PR = "r26"
+PR = "r27"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -347,6 +347,7 @@ do_configure() {
 
        ./autogen.sh
 
+       export varprefix=${localstatedir}
        oe_runconf
 }