]> code.ossystems Code Review - openembedded-core.git/commitdiff
recipes-extended: replace virtclass-native(sdk) with class-native(sdk)
authorRobert Yang <liezhi.yang@windriver.com>
Sat, 27 Oct 2012 08:48:17 +0000 (16:48 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 2 Nov 2012 16:15:30 +0000 (16:15 +0000)
The overrides virtclass-native and virtclass-nativesdk are deprecated,
which should be replaced by class-native and class-nativesdk.

[YOCTO #3297]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/bzip2/bzip2_1.0.6.bb
meta/recipes-extended/ghostscript/ghostscript_9.05.bb
meta/recipes-extended/groff/groff_1.20.1.bb
meta/recipes-extended/gzip/gzip_1.5.bb
meta/recipes-extended/perl/libtimedate-perl_1.20.bb
meta/recipes-extended/pigz/pigz.inc
meta/recipes-extended/stat/stat_3.3.bb
meta/recipes-extended/texinfo/texinfo_4.13a.bb
meta/recipes-extended/unzip/unzip_6.0.bb

index d03b57d33a2dfd834d587848c814df126b0d45c1..6e160cd3e0de59e1be500f9e68caa1953710658c 100644 (file)
@@ -25,7 +25,7 @@ ALTERNATIVE_PRIORITY = "100"
 ALTERNATIVE_${PN} = "bunzip2 bzcat"
 
 #install binaries to bzip2-native under sysroot for replacement-native
-EXTRA_OECONF_virtclass-native += "--bindir=${STAGING_BINDIR_NATIVE}/${PN}"
+EXTRA_OECONF_class-native += "--bindir=${STAGING_BINDIR_NATIVE}/${PN}"
 do_configure_prepend () {
        cp ${WORKDIR}/configure.ac ${S}/
        cp ${WORKDIR}/Makefile.am ${S}/
@@ -42,6 +42,6 @@ FILES_libbz2-staticdev = "${libdir}/*.a"
 SECTION_libbz2-staticdev = "devel"
 RDEPENDS_libbz2-staticdev = "libbz2-dev (= ${EXTENDPKGV})"
 
-PROVIDES_append_virtclass-native = " bzip2-replacement-native"
+PROVIDES_append_class-native = " bzip2-replacement-native"
 BBCLASSEXTEND = "native nativesdk"
 
index 1c18b217daa7a7b901e89672f7317cbec5af7c16..1fdcb997e707deedc7673d8ef1912f2a6018263e 100644 (file)
@@ -18,7 +18,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c5326026692dbed183f0558f926580f8"
 PR = "r3"
 
 DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
-DEPENDS_virtclass-native = ""
+DEPENDS_class-native = ""
 
 SRC_URI_BASE = "http://downloads.ghostscript.com/public/ghostscript-${PV}.tar.gz"
 
@@ -30,7 +30,7 @@ SRC_URI = "${SRC_URI_BASE} \
            file://ghostscript-9.05-NOT-check-endian.patch \
            "
 
-SRC_URI_virtclass-native = "${SRC_URI_BASE}"
+SRC_URI_class-native = "${SRC_URI_BASE}"
 
 SRC_URI[md5sum] = "f7c6f0431ca8d44ee132a55d583212c1"
 SRC_URI[sha256sum] = "593f77f7584704bdf9de41598a084a4208c3ad3b940a1de1faaf8f59a15cc207"
@@ -80,18 +80,18 @@ do_install_append () {
     chown -R root:lp ${D}${sysconfdir}/cups
 }
 
-python do_patch_virtclass-native () {
+python do_patch_class-native () {
     pass
 }
 
-do_compile_virtclass-native () {
+do_compile_class-native () {
     mkdir -p obj
     for i in genarch genconf mkromfs echogs gendev genht; do
         oe_runmake obj/aux/$i
     done
 }
 
-do_install_virtclass-native () {
+do_install_class-native () {
     install -d ${D}${bindir}/ghostscript-${PV}
     for i in genarch genconf mkromfs echogs gendev genht; do
         install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
index c7da1b4178e70c6478607eeda1cab495d1792573..157365b2a739b3c68d998fe1f1a1b16257527452 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI[md5sum] = "48fa768dd6fdeb7968041dd5ae8e2b02"
 SRC_URI[sha256sum] = "b645878135cb620c6c417c5601bfe96172245af12045540d7344938b4c2cd805"
 
 DEPENDS = "groff-native"
-DEPENDS_virtclass-native = ""
+DEPENDS_class-native = ""
 
 inherit autotools
 
@@ -44,7 +44,7 @@ do_install_append() {
        done
 }
 
-do_install_append_virtclass-native() {
+do_install_append_class-native() {
        # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
        # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
        for i in afmtodit mmroff; do
index 2c6917d234a975c95fb07b744be3ebda9c448d18..f7b859374a3dab306f3077dfd5197430e74aaca0 100644 (file)
@@ -2,7 +2,7 @@ require gzip.inc
 
 PR = "r0"
 
-PROVIDES_append_virtclass-native = " gzip-replacement-native"
+PROVIDES_append_class-native = " gzip-replacement-native"
 NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
 
 BBCLASSEXTEND = "native"
index 12439cf727b9a5941fb2c8946ee2502c83b68520..780f77484c3d725526e3cf5775ac2bd267794518 100644 (file)
@@ -13,7 +13,7 @@ inherit cpan allarch
 
 BBCLASSEXTEND = "native"
 
-RDEPENDS_${PN}_virtclass-native = ""
+RDEPENDS_${PN}_class-native = ""
 RDEPENDS_${PN} += "perl-module-carp perl-module-exporter perl-module-strict perl-module-time-local"
 
 SRC_URI[md5sum] = "7da7452bce4c684e4238e6d09b390200"
index 3721c9786e804e7d0b8b8f9633676d6906ce15e8..c897f15d7d8763e11693b21c9327cc315947d0d8 100644 (file)
@@ -12,7 +12,7 @@ PR = "r1"
 SRC_URI = "http://zlib.net/pigz/pigz-${PV}.tar.gz \
            file://ldflags.patch"
 
-PROVIDES_virtclass-native += "gzip-native"
+PROVIDES_class-native += "gzip-native"
 
 DEPENDS = "zlib"
 
index b7666f065c3efd8f4c2363a86bd1712221059b74..73e0873f81a52c5c1b1c61632a0fed6190450a5b 100644 (file)
@@ -18,7 +18,7 @@ do_install() {
        install -m 644 stat.1 ${D}${mandir}/man1
 }
 
-#do_install_virtclass-native() {
+#do_install_class-native() {
 #      install -d ${D}${bindir}
 #      install -m 755 stat ${D}${bindir}
 #}
index 50892ce2cf264e8fd8b288dff9b81354dd63a883..327faabddd6c2abdec4bee46ed3826f399a97d2a 100644 (file)
@@ -9,10 +9,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=adefda309052235aa5d1e99ce7557010"
 PR = "r5"
 
 DEPENDS = "zlib ncurses texinfo-native"
-DEPENDS_virtclass-native = "zlib-native ncurses-native"
+DEPENDS_class-native = "zlib-native ncurses-native"
 
 TARGET_PATCH = "file://use_host_makedoc.patch"
-TARGET_PATCH_virtclass-native = ""
+TARGET_PATCH_class-native = ""
 
 SRC_URI = "${GNU_MIRROR}/texinfo/texinfo-${PV}.tar.gz \
            file://texinfo-4.12-zlib.patch \
@@ -44,7 +44,7 @@ do_install_append() {
        mkdir -p ${D}${datadir}/${tex_texinfo}
        install -p -m644 doc/texinfo.tex doc/txi-??.tex ${D}${datadir}/${tex_texinfo}   
 }
-do_install_append_virtclass-native() {
+do_install_append_class-native() {
        install -m 755 info/makedoc ${D}${bindir}
 }
 
index e11f9f7781a038fd9aa97a0ae4e8c64d5f49897f..a1547fc3b9d6cd609e72333d9f8514d62d8071e5 100644 (file)
@@ -16,7 +16,7 @@ S = "${WORKDIR}/unzip60"
 EXTRA_OEMAKE += "STRIP=true LF2=''"
 
 export LD = "${CC}"
-LD_virtclass-native = "${CC}"
+LD_class-native = "${CC}"
 
 do_compile() {
         oe_runmake -f unix/Makefile generic