]> code.ossystems Code Review - openembedded-core.git/commitdiff
make-mod-scripts/kernel-devsrc: Fix objtool issues
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 Mar 2018 13:02:20 +0000 (14:02 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 29 Mar 2018 23:28:38 +0000 (00:28 +0100)
Kernels which use tools/objtool can now fail when building external modules
due to objtool being missing, the generated files can also cause problems
for kernel-devsrc.

Ensure objtool is generated in make-mod-scripts by also calling
"make prepare".

For devsrc, delete the generated binaries since they'd be native
binaries and unsuitable for the target.

The oeqa kernel module tests also need to have the additional "make prepare"
step added.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/lib/oeqa/runtime/cases/kernelmodule.py
meta/recipes-kernel/linux/kernel-devsrc.bb
meta/recipes-kernel/make-mod-scripts/make-mod-scripts_1.0.bb

index 11ad7b7f01b519ddee7875296f9549bdb3a5b64b..de1a5aa4457ea24125d618c801a7725bcfd3936e 100644 (file)
@@ -28,7 +28,7 @@ class KernelModuleTest(OERuntimeTestCase):
     @OETestDepends(['gcc.GccCompileTest.test_gcc_compile'])
     def test_kernel_module(self):
         cmds = [
-            'cd /usr/src/kernel && make scripts',
+            'cd /usr/src/kernel && make scripts prepare',
             'cd /tmp && make',
             'cd /tmp && insmod hellomod.ko',
             'lsmod | grep hellomod',
index c1b5b7786d7c25306e6b1dcd0b1f16962a95a665..8bbfa23e4b86296b98eee73ba89e6b42fff4226a 100644 (file)
@@ -69,6 +69,13 @@ do_install() {
                 cp ${B}/arch/powerpc/lib/crtsavres.o $kerneldir/arch/powerpc/lib/crtsavres.o
         fi
 
+        # Remove fixdep/objtool as they won't be target binaries
+        for i in fixdep objtool; do
+                if [ -e $kerneldir/tools/objtool/$i ]; then
+                        rm -rf $kerneldir/tools/objtool/$i
+                fi
+        done
+
         chown -R root:root ${D}
 }
 # Ensure we don't race against "make scripts" during cpio
index d63701e5a05ae3073ecf952748be68476471ef4c..97c58c5233112205970651fccaa850ac6ba36bec 100644 (file)
@@ -22,5 +22,6 @@ EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="
 do_configure() {
        unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
        oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
-                  -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts
+                  -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
+
 }