]> code.ossystems Code Review - openembedded-core.git/commitdiff
xwayland: Add xkbcomp runtime dependency
authorTom Hochstein <tom.hochstein@nxp.com>
Wed, 19 Jan 2022 23:48:52 +0000 (17:48 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Feb 2022 09:01:58 +0000 (09:01 +0000)
Trying to run an xterm fails with the error:
xterm: Xt error: Can't open display: :0

Checking systemctl status weston shows an error:
Jan 19 21:24:16 imx8mq-evk weston[396]: sh: line 1: /usr/bin/xkbcomp: No such file or directory

Adding xkbcomp to the rootfs fixes these errors. Checking the history
one finds that the runtime dependency for the old xserver was
removed because it wasn't in the correct location [1], then restored
because it was still needed [2].

[1] https://github.com/openembedded/openembedded-core/commit/bdcc5e8f1286d288baf410458efc39a59b68d751
[2] https://github.com/openembedded/openembedded-core/commit/f2330ebc3071d780cbc6d1ddab5c54bfadf8fffc

Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xwayland/xwayland_21.1.4.bb

index 029123b875baf9e3e4a2f5baaddbbbc412b9ba94..cbf4f1c658ecb8107851cea960581944129bc98f 100644 (file)
@@ -42,3 +42,4 @@ do_install:append() {
 
 FILES:${PN} += "${libdir}/xorg/protocol.txt"
 
+RDEPENDS:${PN} += "xkbcomp"