]> code.ossystems Code Review - openembedded-core.git/commitdiff
weston-init: Use bitbake path variable
authorTom Hochstein <tom.hochstein@nxp.com>
Thu, 9 Jun 2016 19:27:05 +0000 (14:27 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 12 Jun 2016 22:42:38 +0000 (23:42 +0100)
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/wayland/weston-init.bb
meta/recipes-graphics/wayland/weston-init/weston-start

index e4e2701af734a85feda97c726bafc5bf8ab91918..291cd16b2ae0e24c8429fbdfc45a76cad3732251 100644 (file)
@@ -15,6 +15,7 @@ do_install() {
        # Install weston-start script
        install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start
        sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start
+       sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start
 }
 
 inherit allarch update-rc.d distro_features_check systemd
index 72ba4b70790ea22b49ee5c13afa873242963e524..4b41576103ab51a4bc5ab0f58717e6facf7dbb54 100755 (executable)
@@ -69,4 +69,4 @@ if test -z "$XDG_RUNTIME_DIR"; then
     chmod 0700 $XDG_RUNTIME_DIR
 fi
 
-exec openvt $openvt_args -- $launcher $weston_args --log=/var/log/weston.log
+exec openvt $openvt_args -- $launcher $weston_args --log=@LOCALSTATEDIR@/log/weston.log